Jump to content
karinmc

Exporting SVG from Designer results in several problems

Recommended Posts

I have recently switched over to Affinity Designer full time from adobe products after dabbling for a couple years. I'm rebuilding a document that I was originally done in Adobe illustrator. I'm exporting it as an svg file to be used with a program call Sure Cuts A Lot (SCAL) which I use to cut designs on a digital cutter. 

I'm having several problems opening the file in SCAL.

First off, the file is more than 2x the size it was designed to be.

Secondly, all elements are not visible when opened in SCAL. 

Thirdly, there is a dot that is appearing on the top right corner of the design which seems to be measured with the size but it isn't part of the design and can't seem to be removed. 

Precision for the size of the elements I'm cutting is paramount as are the missing elements. I print the document first after designating some lines as print lines and others as cut lines. After the document is printing I then cut the design out. This is a rather large problem that I need to fix, ASAP!!

See photos below:

The first shows the difference in scale with how it should look vs what appears when imported. Also, see the black dot to the upper left that appears?

The second picture shows the preview of the file with text on it but, as you can see when its placed in SCAL the image has no text.

The last picture shows the document in affinity designer with all elements as it should be. 

I hope i'm being clear, and I hope there is a fix that I am just missing when I'm trying to export.

Screen Shot 2018-08-31 at 4.10.11 PM.png

Screen Shot 2018-08-31 at 4.12.06 PM.png

Screen Shot 2018-08-31 at 4.13.22 PM.png

Share this post


Link to post
Share on other sites

I'm having the same problem with exporting SVG files into 'Brother Scan n Cut' software. I have also tried opening SVG files made in Designer with Inkscape, Serif DrawPlus, even back into Designer itself, all open up with different sizes. Yet make an SVG file with Serif DrawPlus and all is well no matter where I open the file. Needs a  solution ASAP.

Also found this also happens when exporting GIF files.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×