Jump to content
You must now use your email address to sign in [click for more info] ×

Affinity Designer Windows - Setup cannot continue because a previous version requires your computer to be restarted

Recommended Posts

I've just bought and downloaded Affinity Designer for Windows. Whenever I try to run the installer I get this message:


"Setup cannot continue because a previous installation requires your computer to be restarted. Please restart your computer and rerun Setup."


I have now restarted my computer twice since then and I still get the message when I run Setup.

Since getting this error I have also successfully installed the Public Beta of Affinity Designer, restarted, run it (got the beta ended message), then uninstalled it.


But subsequently, when running the full version Setup I still get the same error message.


Any help gratefully received.  :(


Link to comment
Share on other sites

  • Staff

Hi CreativeCortex,

Welcome to Affinity Forums :)

Press CRTL + ALT + DEL, then select Task Manager and check if you have any instance of the Affinity setup program running. If so right-click on it and select End Task. Then try install Designer (or Photo) again.

Link to comment
Share on other sites

Hi MEB, thanks for the suggestion, unfortunately it didn't work.


There were no other affinity processes or applications running listed in task manager.


I tried installing again in any case but still get the same error:

"Setup cannot continue because a previous installation requires your computer to be restarted. Please restart your computer and rerun Setup."


I imagine there must be some registry entry, or 'lock' file, that is fooling the setup program into thinking there is a reboot needed. But I have now rebooted enough times for all of us.  :unsure:


What's even more bizarre is that there was no previous installation except perhaps the beta. But I already installed and uninstalled that successfully, so this is purely an issue with the full version Setup.


Any other ideas? Many thanks for the help.

Link to comment
Share on other sites

I think I have made some headway. This is related to the .NET Framework installation that Affinity requires. There is no sign of it in the task manager, but, if I try to 'repair' the .NET Framework installation I get exactly the same error.


I am now uninstalling .NET in order to let it install again from scratch, and will feedback here on how it works.

Link to comment
Share on other sites



First, this is primarily a problem with the windows automatic updater. My solution was horribly complex but in case anyone gets this problem I'm sharing links below:


1) First I backed up all of my essential files, downloads and software, and then did a factory reinstall on my PC.


2) Then I applied the fixes described in this Microsoft Tech Support article: https://answers.microsoft.com/en-us/windows/wiki/windows_7-update/fix-windows-7-update-stuck-on-checking-for-updates/ad6cfeef-232a-49b4-a57b-39978eea6630?rtAction=1478992206279


3) The above article doesn't make it absolutely clear, but after each reboot you need to Start > run > CMD as Administrator, and then enter: net stop wuauserv before continuing.


4) I then installed Windows 7 Platform Update: https://www.microsoft.com/en-gb/download/details.aspx?id=36805


5) I could then install Affinity Designer for Windows


6) You might be able to skip step 1, and just try the fixes from step 2. 


Enjoy  :D

Link to comment
Share on other sites

  • 2 months later...

I have the same problem ...... every time I try to download it this message comes up (being going on for months now, luckily I have another program SerifPhotoPlus to use in the meantime) ... my computer is installing other programs quite happily ...


" Setup  cannot continue because a previous installation requires your computer to be restarted.  Please restart your computer and rerun Setup"


I had the beta version installed so I uninstalled that.  Still the same message comes up ... again and again despite days of restarts ...


 I'd appreciate your  help please .......... thank you :)  (I really cannot do a factory reinstall etc as suggested above)



Link to comment
Share on other sites

  • 6 months later...

I second what LilS said. I can not do a factory re-install, just to make this work.


It has been 6 months since anyone has said anything about a solution to this problem. Come on!


Someone from affinity-serif, please provide information on how to fix this error. This deal-breaker problem has to be addressed.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.