Jump to content

Affinity Designer For beginners Too: Alt Clicking Add Button Causes Shape to Disappear

Recommended Posts

I'm working my way through the Affinity Designer tutorial videos to familiarize myself with the program, and there's some inconsistent behavior between what happens in the app on my machine and in the video.


When alt-clicking the add button to create a compound shape, the video tutorial merges the shapes into a non-destructive compound shape. Yet, on my computer, doing so causes the top shape to disappear.






The strange part is, the top shape will reappear if the position of the tear drop is moved far away from the top shape:




or moved higher up into the top shape:




Additionally, even though both shapes have the stroke set to none, there's still a gap between the two shapes, which indicates that it's not possible for Affinity Designer to do a non-destructive compound addition properly:




It's very confusing to have the program behave so inconsistently when following an in-house tutorial video — is this (another) bug, or did I miss a step and not set an option/preference properly?

Link to comment
Share on other sites

Turns out, it was partial user error, partial software error - the pen tool in smart mode added some points at overlapping angles when I was clicking about trying to follow the video, and I'm not familiar enough with vector editing to have figured it out immediately. The cause for the issue only became apparent once I moved onto the next step in the video and tried to use the corner tool.

Link to comment
Share on other sites


I ran into the same problem working through the tutorials.  Contacted the Forum and received the following answer:


Hi PaulDean,

Welcome to Affinity Forums  :)

This is due to a bug that prevents the boolean operation Add to work properly (already logged).


To "fix" your project do the following:

- select the shape on the top (the large one)

- change to the Node tool and drag a marquee around all nodes of the shape

- click on the Smooth button in the Convert section on the context toolbar

You can now perform the add operation as indicated in the tutorial, selecting both shapes and pressing and holding ⌥ (option/alt) while clicking on the add icon.

The result should be correct.


This 'fixed' the problem and I went on and completed most of the tutorials.  Hope it helps.

PaulDean, Ocala, FL

Link to comment
Share on other sites

  • 9 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.