Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Urgent - Publisher won't export to a PDF


Recommended Posts

Publisher won't export my workbook file as a PDF. I need this asap to send off to my editor. I get the export item box with the advancing blue line and then, at the very end I get a notice that says "an error occurred when exporting to:": 
Thanks for any help you can give!

Screenshot 2022-10-18 180213.png

Edited to add: Publisher will allow me to export other similar files to PDF without the error. I thought I should test that to give you a bit more context. 🙂

Link to comment
Share on other sites

There is no general reason for this error message. One culprit could be a specific object causing the issues, another reason maybe a font issue, either generally with a certain font file or locally on your computer only. To limit down a possible culprit you could try to export certain parts / pages or selections only.

It would be a lot more efficient to get a file uploaded than just a short description. It also might help to know your PDF settings, respectively whether an export works as a rasterized file format (e.g. jpg) and if the affected document did ever export before in a former layout state without harm – and, if yes, what got changed in between.

"Other similar files" doesn't help yet as info because we have nothing to compare with: similar to what / in what aspects? All you told us about the failing document is that it's failing. So, similar files would fail, too.

Another option to inform the forum about the situation with your document in more details could be a protocol of the export process. This thread tells the way to enable it:

macOS 10.14.6, MacBookPro Retina 15" + Eizo 27"

Link to comment
Share on other sites

Thank you for the suggestions. I will share the file privately with the official Affinity people if they ask me to. :) I'm attaching the PDF log to this post.

My PDF settings are as follows:
Preset: PDF for print
Rasterize: Unsupported properties
Downsample images above DPI 375
Resampler: Bilinear
Use DPI: 300
Allow JPG compression - quality 98
Compatibility: PDF 1.7 Acrobat 8
Color Space: As document
ICC Profile: Use document profile
Embed ICC profile

I exported the file a couple of times. Not much has changed except I moved from a Windows 10 computer to a Windows 11 computer. I've had issues with this file before and posted in this forum (this file was crashing repeatedly, especially when I tried to do a fix for "One or more tables of contents entries need updating" in the preflight area. Deleting a Windows update as suggested made it stop crashing.

Another problem I just noticed this file is having: The preflight area is still showing me the notice "One or more tables of contents entries need updating". When I click it, it acts like it's trying to fix it (and for some reason my TOC totally changes its layout and the fonts used, etc. when I press it) but the message doesn't go away no matter how many times I press the fix button.

When I mention "other similar files" this file is based off of some workbooks I made previously, so it has all the same settings and also used some of those original pages. Basically, I used the other workbooks as templates, deleted some pages, and added material. So, they aren't exactly the same, but they do use the same settings and same page templates, etc.

I just tried exporting a much smaller section and the export worked. I'm going to try to figure out what section is causing the issue and will explore if there is a url causing issues as per tudor's suggestion. Thank you both so much for your suggestions and help!


Edited to add: I took out all the urls and that didn't change anything. 
 

pdflib.log

Link to comment
Share on other sites

2 hours ago, thomaso said:

Can you tell what kind of object or setting was causing the issue? Resources, Text, Links, … ?

I believe it was a .jpg that was causing the issue. :) I'm attaching the malfunctioning page, in case anyone wants to dig deeper.

1 hour ago, pbasdf said:

From a quick (and possibly ill-informed) look at the PDF log, it seems like the problem lies with the embedded ICC profile in an image named "PdfIm_804.jpg" (though that might be an internal name for an embedded image??).   

I believe you are correct! :) Thank you for taking a look!

I appreciate everyone's help so very much! I was ready to pull my hair out, lol. I'm grateful to have the issue fixed! ❤️ 

malfunctioning page.afpub

Link to comment
Share on other sites

54 minutes ago, guesthollow said:

I believe it was a .jpg that was causing the issue. :) I'm attaching the malfunctioning page,

If I deactivate the Outline Effect from the image layer and replace it by a 'normal' Stroke then I can export (preset 'for print') without error. malfunctioning page_stroke.pdf ( ... Aside that, this .afpub with 23 MB appears to contain a lot of data garbage which could be of interest for Serif.)

• Before (causes export error):

2018732540_imagebordereffekt.thumb.jpg.1b26eed471744d398cebf63124e3226b.jpg

• After:

1645417347_imageborderstroke.jpg.a84a57e223354b3e4391d28c79031996.jpg

macOS 10.14.6, MacBookPro Retina 15" + Eizo 27"

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.