Jump to content
You must now use your email address to sign in [click for more info] ×

Publisher 1.9.0 - screen artefacts

Recommended Posts

Current production version of Publisher, purchased from Serif store.

macOS Big Sur, v11.2.1

Mac mini M1: 16GB RAM, drive only half full - so plenty of free space.

Display: Samsung LU28R55 - 28.5-inch (3840 × 2160); directly connected via supplied HDMI cable to HDMI port on Mac mini.

  1. Launch Publisher directly (click on app in Dock, use Spotlight, Alfred, etc - as opposed to clicking an existing document)
  2. Dismiss the Welcome screen
  3. File > New
  4. Double-click, for example, A4 (problem also seen with A3 and A5 - I assume this will happen for many/all sizes)
  5. Observe randomly drawn artefacts, which vary each time this is repeated
  6. Double-click on the icon for Page 1 to clear the artefacts

Quit, repeat.  Was originally happening every time.  This appeared pretty reliable - until I set out to make a nice recording for you.  Then, of course, it occasionally worked properly.

Changing resolution down from 3840×2160 to produce the following video seemed to prevent the problem.  Returning to the highest resolution brought the problem back.

I didn't try a Safe Boot, but the recording was produced after holding down the shift key at login to prevent a selection of utilities loading during this session.  Of course, it also happens with a regular full login.

The video shows the process repeated twice to demonstrate different artefacts.



—— Gary ——

Photo/Designer/Publisher: Affinity Store, v2.1.1 release

Mac mini (M1, 2020), 16GB/2TB, macOS Ventura 13.4.1(c) • MacBook Pro (Intel), macOS Ventura • Windows 10 via VMware Fusion • iOS: current release

Link to comment
Share on other sites

  • 2 months later...

Hi @SPaceBar - no worries, good to hear from you.  I was originally going to explain that within a day or two of posting this, the problem died away and, apart from a possible single sighting just last week, hasn't appeared again since then.

But I thought I should review my old notes and watch the video again and try once more before responding.  Then twice more, then three times more.  Nada.  When it got to about a dozen or so attempts, I decided to fire up Photo from the Dock and it hidden in the background (no documents open).  And like a charm, something like the next six attempts out of seven resulted in artefacts similar to those already demonstrated.  #woohoo!

NB for clarity, I'm currently on Publisher 1.9.3, from the Serif Store; my Mac's running the Big Sur 11.3.1 update that came out yesterday - so, all bang up to date.  The current session was from a cold boot earlier this evening and has my normal compliment of background utilities and apps like Music playing away in the background.  I'm operating with admin rights available on this account.

I was using the full 3840 × 2160 resolution, as I normally do.  So, since you asked, I dropped the res and see if the problem persisted - and that stopped it.  I tried the first intermediate resolution (2560x1440) and then dropped to plain old 1920x1080.  Nothing.  On returning to the full res display, I've not been able to repeat the artefacts this evening.

It's a bit late now to reboot and and try again afresh, but I'll do that tomorrow, if I can find the time, to see if I can replicate what I found again tonight.

Not mentioned previously, my performance settings are unlikely to have changed significantly from mid-February; currently they are: 


Let me know if you have any more questions or specific suggestions to test.

For the record, this is obviously not a high-impact problem just now and, so far, easily resolved.  I've not spotted any other posts that seem to suggest this problem, so I appear to be a lone crank voice in the wilderness.  I'm looking on it more as an academic exercise to help you get to the bottom of it and hopefully find a proper fix.  :) 

—— Gary ——

Photo/Designer/Publisher: Affinity Store, v2.1.1 release

Mac mini (M1, 2020), 16GB/2TB, macOS Ventura 13.4.1(c) • MacBook Pro (Intel), macOS Ventura • Windows 10 via VMware Fusion • iOS: current release

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.