Jump to content

Recommended Posts

Version 4 ICC files do not seem to work with MacOS 11 and Affinity Photo.

After contacting the paper company and working through my problem, we discovered that using version 4 ICC files when printing from Affinity Photo produce an incomplete print. In my case just yellow and light cyan. They kindly sent me a version 2 ICC profile of the same file, and it worked.

Has anyone else been having this problem? 


MacOS 11.1

Epson SC P800

Link to comment
Share on other sites

  • Moderators

@Aaron C Welcome to the forums.

We're aware of an issue with existing ICC profiles not being assesible in our apps after updating to Big Sur. I wonder if this is related to that in some way as I haven't seen any other reports. Have you tried adding the version 4 ICC profiles to Affinity Photo using File > Import ICC Profile and then doing a test print, to see if the same issue occurs.

If it does, could you upload copies of version 2 & 4 profiles and I can pass this over to the developers to look into.

Link to comment
Share on other sites

  • 2 weeks later...

Hi Lee,

I have uploaded the 2 Canson ICC profiles for Platine Fibre Rag for you to review. My question...

This has been my workflow: I open my test image, leaving the ICC Profile settings as is (Display P3), I go to File > Print. In the dialog panel under Color Matching, I have been selecting ColorSync and assigning the ICC Profile for the paper there. This has been working well for me up until the version issue was discovered. So, if I Import ICC Profile into the image as you suggest, what are the steps I take in the Print Dialog?

Canson_Platine_Fibre_Rag_P800_UPPPL_v2_12-2020.icc cifa_p800_platine310_p_bk.icc

Link to comment
Share on other sites

  • 1 month later...


I have the same problem as Aaron with a different Canson ICC profile. Baryta Prestige. I printed the file from the Epson Print Layout application using the version 4 ICC profile without any issues but only get yellow and light cyan if using the same ICC profile in Affinity Photo. Very expensive paper to be throwing away.  

Link to comment
Share on other sites

Hi Lee and PMullins,

An update:  the MacOS I am using has been updated to 11.2.1

Using the same test image with the same settings in Affinity Photo, with Canson paper and their specific v4 printer profile applied as detailed in my January 5 Post, I tried another test. This time, no problems - no yellow and cyan only issue that I saw before. I can only assume that Apple fixed a bug that they would not acknowledge as one.

Going forward, I am a little skittish and will be doing tests before loading up the Canson paper. As PMullins said, very expensive paper to be throwing away. If the v2/v4 issue pops up again, I will add an update to the thread.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.