Jump to content

Cannot export pdf - nothing works

Recommended Posts

Having big problems exporting to pdf; the dreaded and very unhelpful  "An error occurred while exporting to:…”

Version 1.8.6. MacOS 10.15.7

File is normal A3, 20 pages, jpegs, tiffs, pngs – nothing unusual. Tried normal troubleshooting: restarting, giving more memory, software rendering, looking for bad links, strange graphics, old broken fonts, etc but no luck.

No pdf preset works, built-in or own. Strange anomaly: Export window never finishes calculating Estimated File Size.

Beta version opens file, but crashes on trying to choose any pdf export preset.

Now a deadline is looming. Cannot afford to loose this gig.

Link to comment
Share on other sites

Ok, uploaded now. 

Maybe a contributing factor to problems: this is a file which has been "re-used" a couple of years, where I open up the file from last year, empty out old stuff to put in the new. Could there be some old cruft left? If I remember correctly this project has had similar problems earlier,  but they resolved with a new version of the app. Might even be that the original file was made with one of the pre-release betas…

Edited by Rabari
additional info
Link to comment
Share on other sites

Ok, thanks! Strange combination indeed, for files coming out of Affinity Photo :10_wink: Sorry, untouched photos. Why do people scan B/W photos in RGB?

Could problematic files like these be flagged in Pre-flight, perhaps?


Link to comment
Share on other sites

The exact same thing happened to me just now. The other day I created a new document in AP 1.8.6 on Catalina 10.5.7, and exported it without issues. 

Today I opened a document created in an earlier version, 1.8.x, and met the "An error occurred when exporting ..." message. Tried all possible PDF export settings and made sure that all photos were the same profile/ICC as the document settings (Adobe RGB), and checked that no fonts were reported missing in Fonts Manager. The document is a modest 32 page A5 with nine pictures in it. When exported in the previous version of AP, the one it was created with, the PDF export went without problems. 

Scratching my head, hoping for a solution ... 

Link to comment
Share on other sites

Sorry for replying late. I downloaded the beta, opened the document and found two picture text wraps missing, but apart from that it opened and exported to pdf perfectly. 

So, whatever your dev team did there, please ask them to hold on to it! :)

A great many thanks from Sweden, and keep up the good work. Love your Affinity apps.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.