Jump to content

All afinity apps crash on start up on macos Catalina


Recommended Posts

Hi, on starting any of the affinity apps they crash and will not open. I have deleted the apps and reinstalled. No difference. I have deleted the container files. No difference. I have given the apps all full disk access. No difference. And each time I restarted.

The error reports are attached.

 

Thanks,

Peter

 

Affinity Photo [582] crash file

ProcessAffinity Designer [763]

Link to comment
Share on other sites

  • Moderators

Hi Peter,

Welcome to the Affinity Forums,

Looking at the reports, it looks like it is crashing due to a Type 1 font installed on your machine. Could you attach a screenshot showing all the installed fonts in the 'User' section of Font Book please? If you disable all the of the fonts in the user does it allow Affinity to start up?

Link to comment
Share on other sites

  • Moderators

Thanks for those files. It appears to be the OTF files in your zip that are causing the problem. If I try to drag them into Font Book that will crash straight away for me - in the same location listed above in your crash, so it doesn't appear to be anything we can do! You should be ok with using the TTF versions however.

Link to comment
Share on other sites

  • 1 month later...

I'm experiencing the same all-apps-crash-on-open problem. I've used Font Book disable all the User fonts. No change.  I've used Font Book to find defective fonts. Almost all were already disabled. At least one, Savoye LET, did not let me disable it. It does seem to be a font issue, as you can see from the attached bug report which starts by mentioning font issues. But I can't figure out what the problem font is. I can send you any files or screen shots you want. Any ideas?

The only factor I can see was that I set up the Auction Bay for Sniper app just before this issue developed and it installed an ebay font whose name I forgot. Perhaps that created the problem. Also, there seems to be some duplicate fonts with problems, one set of which I can't disable or delete.

Process- Affin.textClipping

Link to comment
Share on other sites

  • Moderators

Hi Mike,

The fonts on a Mac are stored in several locations:

  • Macintosh HD\Users\username\Library\Fonts
  • Macintosh HD\System\Library\Fonts
  • Macintosh HD\Library\Fonts (not always found here)

Could you create separate zips of each of these folders and upload them to our internal Dropbox account below, hopefully this will allow me to reproduce the issue you're having.

https://www.dropbox.com/request/gty7SxoRkZgT5jK9Xxpm

Thanks!

 

Link to comment
Share on other sites

Many thanks, Sean, for such a quick response. I layout books for a living, so there are a lot of fonts now uploaded to Dropbox as three zip files. The previous poster's problem was with an OTF font, so I used Font Book to create a smart collection of Open Type fonts. I couldn't find a way to upload that as a text list, so you will find them as three screen captures, Font Lists 1 through 3. Let me know if you'll like them listed some other way.

 

 

Link to comment
Share on other sites

  • Moderators

Hi Mike,

Thanks for the files. I've placed them in the suitable locations on Mojave 10.14.6 (and replicated the smart collection), and unfortunately I'm still unable to cause the crash on run up. Would you be able to try the following for me please.

Go to \Users\username\Library\Containers\ and rename the com.seriflabs.affinityphoto folder to com.seriflabs.affinityphoto.old and then try and run Photo. Let me know if this allows you to get the application running.

Link to comment
Share on other sites

We may be getting closer to the problem. There's no such folder at that location on my main drive. Attached is what a search for that folder by name turned up. All the copies are on OWC-440, which is my Carbon Copy Cloner backup drive. It's not in the user folder of my main drive, OWC-1G. The folder seems to have disappeared a few weeks ago. Could that be the problem? Should I drag the most recent of those backups into  \Users\username\Library\Containers\ or is there another way to create it?

Seriflabs folder.png

Link to comment
Share on other sites

  • Moderators

Thanks for that info Mike, did you purchase the application from the Mac App Store or from the Affinity Store? If you purchased from the Affinity Store then the folder is actually kept in Users\username\Library\Application Support\ and will just be called 'Affinity Photo'. If you do have this try renaming it. 

If you do have the Mac App Store version then it may be worth copying one of those files (from a time you know it was working) back into the Users\username\Library\Containers\ folder.

If that doesn't work, does creating a new user on your Mac allow the applications to start up?

Link to comment
Share on other sites

Yes, I did get all three apps directly from Affinity. I do that whenever I can to ensure that developers get all the money they deserve. And all had to do was rename those folders for Designer, Photo and Publisher as you suggested, and all is well. I'm now back in the Affinity family. Yeah!

You might change your online name to Gandalf the Wizard, because that's what you are. I would have never discovered this. Many, many thanks.

 

 

Link to comment
Share on other sites

  • Moderators

Haha! Might have to find a white hat for my avatar! Great news to hear you're back! Would it be possible for you to zip those folders up and attach them to the Dropbox link above so I can get them passed onto development to see what may have been causing the crashing?

Thanks!

Link to comment
Share on other sites

You deserve that white hat! The files for each app are now in that Dropbox folder, including one for the Publisher beta. I hope that helps. I'm not sure how this trouble arose, especially with all three apps. I've only had two issues with these apps.

1. I've not had much luck getting various plug-ins to work with Photo. They typically don't appear despite my best efforts.

2. About the time of this trouble I was using Designer to tweak some EPS files created in Adobe Illustrator by someone else. I don't know Designer that well, so I may have done something stupid.

Of course neither issue explains why all three apps had something in their folders corrupted.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.