Jump to content
zei

Question about masks in Affinity Designer on iPad

Recommended Posts

Absolutely loving Affinity Designer on the iPad, but there’s one thing that I just can’t figure out - working with masks. I usually start with making a pixel layer lineart drawing, set to multiply. Then I do the colouring, in either pixels or vectors in a layer underneath this. What I then need to do is to remove parts of the lineart that I don’t need anymore. I could of course use the eraser tool, but I prefer to do this in a mask, as I often change my mind about what works or not. However, when I add a masking layer to my pixel lineart layer, the quality of the line suddenly changes radically, almost as if it burns and disintegrates somehow, weakening the overall lineart a lot, without me adding any black to the mask whatsoever. Now I think this effect is kind of cool, but I don’t always want it, and I want to figure out why it happens and how to control it. What I’m looking for is adding a mask so that I can paint out the lines with my pixel persona brush tool, without Designer suddenly changing the quality of my lineart when I add that mask. I’ve watched the tutorials, but found no info to help me with this particular challenge. Should be pretty straightforward and simple, yet this trick eludes me in Designer for iPad. Anyone else encountered this, or have any experience with masking pixel layers in AD? 

- zei

Share this post


Link to post
Share on other sites

Hi @zei & welcome to the forums! :)

I see an odd effect when I apply a mask to a pixel layer in the iPad version, but I would not describe it as a burning or disintegrating effect. To me, it is more of a slight blur & reduction in thickness. The difference may be in how the layers are stacked or with the line art I am using, so if you could explain a bit more about that (or attach a screenshot) it might help.

Regardless, I am not seeing the same thing when I save the file to iCloud & open it in the Mac desktop version of Affinity Designer, so maybe this is a bug in the iPad version or a rendering effect.


Affinity Photo 1.6.7 & Affinity Designer 1.6.1; macOS High Sierra 10.13.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.6.11.85 & Affinity Designer 1.6..4.45 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iOS 12.1.1

Share this post


Link to post
Share on other sites

Thanks for the reply @R C-R. :) Yes, perhaps my description wasn’t quite good or precise enough. But there was as you said, definitely a reduction in thickness. As I tried to make you a screenshot today, the strangest thing happened. When applying a mask, nothing happened. The thickness wasn’t reduced. In other words, it suddenly behaved the way I wanted it to. This was in a new document, so I tried applying masks in the files I was working on yesterday, and the same thing happened - it now all worked correctly, the way it’s supposed to be. Which is weird, as I haven’t done anything differently from yesterday. I haven’t changed any settings, layer properties, order or tool values. Nothing. But as long as it works now, I’m happy.  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×