Jump to content

badjohn

Members
  • Content count

    43
  • Joined

  • Last visited

Everything posted by badjohn

  1. I am quite a new user still finding his way around Affinity Photo. I have just hit an odd problem. The dialogs for levels or white balance adjustment will not appear. Normally I can click on the icon in the layer and the dialog will appear so that I can adjust it. Today, nothing happens when I do that. Also if I add a new Levels Adjustment layer (with the menus of Ctrl+L), a layer appears in the list of layers but the dialog to set the levels does not. Similarly for the white balance adjustment layer. I have tried resetting the studio, restarting, even rebooting, but none of these have helped. I am using Windows 10.
  2. For about a week now, I have been suffering from a recurrent and annoying problems. Every now and then, many dialogs stop working. For example, I press Ctrl+L for a levels layer. The layer appears in the layers list but no dialog to set the levels appears. If I double click the icon next to the layer name in the layers list, the usual dialog does not open. This applies to many others e.g. white balance adjustment. Most recently, I noticed the problem with Gaussian blur. I installed an update this morning, Help / About now says 1.6.1.93, but the problem has reoccured since. I amusing a Dell Inspiron 15 5000 Series running Windows 10 Home, version 1709, OS build 16299.64. After much experimentation, I have found that the problem appears to be connected to my external monitor. When it occurs, if I disconnect the monitor, restart Affinity, and reconnect the monitor then the dialogs reappear. However, they often disappear again. Sometimes they remain operational for a reasonable time and sometimes they fail on the second attempt. I have not detected any pattern to the failures. The laptop's built in monitor is 1920x1080 and the external monitor is also 1920x1080. The monitor is a Dell. I reported this last week but I failed to notice this bugs forum.
  3. Any progress on this issue? It is considering less serious now but it is still a bit annoying that I have to change the laptop's display setting especially since it affects all applications.
  4. Thanks, that's the effect that I want but I might need a few more hints. I am quite new to Affinity and even back the PhotoShop CS3 that I used to use, I have not tried this before. I have recently managed to apply levels and curves selectively: select the area, create an adjustment layer, and edit the selection (typically but it a bit) but I cannot seem to apply that the procedure to this case.
  5. I have an image of a model against a featureless wall. Well, there is no deliberate or desirable featuring to the wall but there are imperfections and shadowing that I don't like. I would like to apply some blur to the wall but not the model. I have tried a few ways but I cannot seem to get it right. I have creates a duplicate of the background and selected the wall successfully but now I need a mask from the selection so I can hide the model and allow the original unblurred image to show through. I cannot seem to get it quite right. Any suggestions?
  6. I have done some more editing and, so far, it is behaving itself. However, the size setting for the laptop monitor is still 100% rather than the default of 125%. I am getting used to it but it is not ideal as it affects all applications and not just Affinity.
  7. I skipped over Windows 8. My work laptop is Windows 7 and the old desktop is XP. However, "Make text ..." sounds vaguely familiar. Yes, if it stays working then I will be happier but there is still an issue. The settings change has had a visible effect. This text that I am typing right now is smaller as a result. It would be nice if Affinity could cope with this setting or at least alert the user to the issue. It was very confusing and frustrating when the dialogs simply did not appear without explanation. It did not even seem as if they had appeared off the monitor.
  8. Thanks. I have just attached DisplaySettings3. The resolution is 1920x1080 again as expected but the "Change the size of text etc" option was 125% on the laptop and 100% on the external monitor. This was not a deliberate choice; as you see in both cases it says "Recommended". I guess that there is some algorithm based on the physical size of the monitors. The external monitor is physically larger which is why I like to edit on it. I switched the size option to 100% and repeated the tests above. The image size issue is still there but to a lesser extent. While Affinity was on the laptop, I clicked Ctrl+0 to check that the image was as large as the workspace would allow. I moved Affinity to the external monitor and the image was larger than before I changed the display settings but not quite as large as it could be. Clicking Ctrl+0 again caused it to enlarge slightly. However, this is a minor point. Possibly useful to you as a symptom but not of serious concern to me. Point 4 above is the same. The Levels dialog opened. Point 5 is also the same. Point 6 is different. The Levels dialog appeared. Point 9 is also different. Again, the levels dialog appears. So, it seems that you have identified the issue. Thank you very much. My apologies for missing the size option, I was concentrating on the pixel dimensions. I am not familiar with this size option. Is it new to Windows 10? I don't see it on my older work laptop or my very old desktop. I won't be able to do much testing in the next few days but I will be using Affinity a lot when I return. I hope that it continues to function. Please don't close this issue yet as I would like to use it more before being sure that the issue is resolved but you can put it aside. I will update it again and I hope that will be to say that it is continuing to work as expected.
  9. Here are some screen shots. Two shots of display settings. The following shots were made using the Windows key and Print Screen. This seems to create an image showing both monitors. 1. I open Affinity. It comes up on the external monitor due to where it was last. I move it to the laptop's own screen as I have learned that that seems to help. I open an image. Image Affinity 1. 2. I double click the icon next to the (Levels Adjustment) layer in the list of layers. As expected the Levels dialog opens. Image Affinity 2. 3. I close the Levels dialog and move Affinity to the external monitor. Image Affinity 3. You can now see me typing this message on the laptop. As a minor question, why does the image no longer fill the available space as it did while on the laptop (both monitors are 1920x1080)? 4. I double click the icon next to the levels layer again. This time it works (I did say that it was intermittent) and the Levels dialog appears on the laptop. Image Affinity 4. 5. I close Affinity and reopen it. This time I do not move it to the laptop. I open the same image. Image Affinity 5. 6. I double click the icon next to the Levels layer (as in step 2) but the Levels dialog does not appear. No image this time as it is identical to the previous image. The double click has no apparent effect. 7. I use Cascade windows from the task bar in case the dialog has opened behind another window. I cannot see it. Image Affinity 7. 8. I open a new image (raw file and I develop it). Image Affinity 8. 9. I press Ctrl+L and a (Levels Adjustment) layer appears in the list of layers but the Levels dialog does not appear. There is no missing image between this and the previous step. Image Affinity 9. Now, as far as I know, I am stuck. The only way that I know to set the levels is to close Affinity and proceed as in step 1: move Affinity to the laptop's built-in monitor before opening the image. This issue is not unique to the Levels dialog but applies to many others. As a result, I must either work only on the laptop's own display (same resolution but physically smaller) or frequently close and reopen Affinity.
  10. Thanks. I'll have a go at that. I cannot do it now as I am working but I will try to do it in the evening. When working: I open an image, press Ctrl+L and a new layer appears in the layer list and a dialog to set the levels appears. When not working: I do the same, the new layer appears in the layer list but no dialog appears. Similarly, if I double click the icon to the left of the layer name in the layer list then when it is working a dialog for the levels appears but when it is not working, nothing appears. Monitor set-up: laptop 1920x1080, external monitor also 1920x1080 and it is positioned to the right of the laptop: both physically and in display settings.
  11. I am new to Affinity. I am running the trial at the moment but I am liking it and will almost certainly but it when the trial ends. However, there are a few work flows which I have not managed to get as smooth as I like. One example is resizing in batch jobs. Is there anyway to save commonly used settings such as file type, size, and quality? E.g. so I could quickly resize a batch to jpg, 900x900, at 90%. I see the macros but, as far as I can figure out, they don't do this job.
  12. On further playing. It might not be necessary to disconnect the monitor; just restart it on the laptop's monitor and open the dialog there. Still a considerable nuisance but a bit better than having to disconnect the monitor. I was worried that I would wear out the HDMI socket. However, I need to perform this procedure about once per image.
  13. badjohn

    Affinity won't reinstall

    Thanks. I have just noticed a new version of Affinity. I was a little nervous about installing it after the pain that I describe above but I am pleased to say that it went smoothly. Help / About now says that I am running 1.6.1.93. A very quick test shows that the Levels dialogs are working but that is without the external monitor. A more thorough test will need to wait for this evening. I have just seen the bugs forum. If I experience the problem again, I will start a new thread there.
  14. Due to another bug, see other posts by me, I attempted a delete and reinstall. Unfortunately, this is failing. So, I have gone from a defective product to nothing at all. The installer fails saying that it cannot find the msi file in C:\Users\john\AppData\Local\Temp\AffinitySetup\648a993a-cc4c-11e7-9431-7c67a2ec0869\. Indeed it is not there, it just created it. I cannot figure out how to get past this.
  15. badjohn

    Affinity won't reinstall

    Thanks. Sorry, I am new and still finding my way around. What's the best way to report an issue? The laptop's built in monitor is 1920x1080 and I have an external monitor which is also 1920x1080. One of the other users suggested starting Affinity with the Ctrl key held down which gives a clear dialog. This worked the first time that I tried it but not again. After the last two failures, I restarted without the external monitor which helped. Fortunately, it seems that I can reconnect it once Affinity is started.
  16. badjohn

    Affinity won't reinstall

    Any ideas om the missing dialogs? Apart from this comment of yours, I have heard nothing from the company, only other users.
  17. It does seem to be connected with the external monitor. After R C-R's tip got it working on the laptop display (no external display), I worked there for a while. Later, I connected the external monitor and the dialogs disappeared again. However, now I had an idea, disconnect the monitor, restart Affinity, check that the dialogs worked (they did). connect the external monitor, and check again. They were still working. A bit of a nuisance but it's a temporary solution. Provided that it works, it could be just chance that it worked this time and this is not the real explanation.
  18. Monitor disconnected and laptop rebooted and the Levels dialog worked - wow! Mind you, a number of other tricks worked just once, e.g. starting Affinity with Ctrl and reinstalling, so the champagne is staying in the fridge for the moment. I cannot connect the second monitor and try or do anything serious at the moment as I need to concentrate on my day job. Thanks for the suggestion.
  19. Just in case that was the issue, I tried Cascade windows and other options from the task bar. I still cannot see the Levels dialog.
  20. R C-R, thanks. I use multiple monitors but both are connected at the moment and I still cannot find the missing dialogs. I have not changed the configuration of the displays since installing Affinity (the first install or the reinstall yesterday). The external monitor is to the right of my laptop; the laptop is always open when in use. I have heard of bugs such as that in other software but it does not seem to match my symptoms as the configuration is stable and I have seen the dialogs appear and disappear with no hardware changes. E.g. they worked just after the reinstall but when I closed and reopened Affinity they had disappeared again.
  21. badjohn

    Affinity won't reinstall

    Sorry, I guess that you were asking I meant. I have another thread about that: Dialog for levels or white balance adjustment not appearing.
  22. badjohn

    Affinity won't reinstall

    Yes, that's the one. At least, now I know that I am not the only one to experience. I am not sure whether I experienced it before a couple of days ago, rarely if I did, but it is pretty much all of the time now.
  23. Granddaddy, thanks - at least that makes me feel less like I am going mad. At the moment, it is easy for me to reproduce since it is not working at all (except for one session after a reinstall). For me, closing and reopening, even rebooting does not help. My set-up is pretty much the same as yours.
×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.