Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Mavericks

New Members
  • Posts

    2
  • Joined

  • Last visited

Everything posted by Mavericks

  1. It's the same for me, tryed several days, nothing happens Howerever when I go to there website, and login than it's working. It's a little bit weird. The message I get:Timeout while waiting for registration service "ready" notification. First I tried the repair option, but that did't work, because my tools where disappeared. I turned back on via studio, but everytime I quit the program , the tools disappear again and must them activate them. Finally I reinstalled the program, and everything works again , exept the message I got ( Timeout....
  2. If I want to open my account in Affinity Photo itself, and I want to Sign in it says my password is not correct. If I go with my browser on Affinty photo I can login. That's weird. Now I can't dowload thy extras that came with the update 190.0 Ask to help me with the problem? Best regards, Peeters marc
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.