Jump to content
You must now use your email address to sign in [click for more info] ×

CANNOT EXPORT WITHOUT RASTER


Recommended Posts

I don't really use much gradients, but today I discovered that I cannot export or copy objects from Affinity Designer to Adobe Illustrator without having all objects with gradients rasterised!! I believe this is the most ridiculous limitation ever. I wasn't sure if this was related to the complexity of the design, so I tested with by creating a new document and adding a simple rectangle with basic linear gradient. After copying the element to Illustrator, I got en error that "An unknown shading type was encountered". And indeed, the element became a path with colour bitmap inside. 

I just cannot believe it.... Maybe I'm wrong, but I think it worked properly in some earlier versions of Affinity Designer. Well. this software is becoming more useless to me over time... I hope it's just a temporary bug.

Link to comment
Share on other sites

11 hours ago, waveman777 said:

I just cannot believe it.... Maybe I'm wrong, but I think it worked properly in some earlier versions of Affinity Designer. Well. this software is becoming more useless to me over time... I hope it's just a temporary bug.

Gradients are working as expected for me copy / pasting  back and fourth between Publisher beta 1.9.1.967 (latest) and illustrator cs5 (15.0.2) - even rotated gradients inside shapes inside shapes x5 remain fully editable both ways, although skewing the gradient even slightly seems to rasterise once pasted into illustrator

Daz1.png

Mac Pro Cheese-grater (Early 2009) 2.93 GHz 6-Core Intel Xeon 48 GB 1333 MHz DDR3 ECC Ram, Sapphire Pulse Radeon RX 580 8GB GDDR5, Ugee 19" Graphics Tablet Monitor Triple boot via OCLP 1.2.1 - Mac OS Monterey 12.7.1, Sonoma 14.1.1 and Mojave 10.14.6

Affinity Publisher, Designer and Photo 1.10.5 - 2.2.1

www.bingercreative.co.uk

 

 

 

 

 

Link to comment
Share on other sites

  • 5 months later...
  • 5 months later...

After a couple of times i faced off on this problem (and if i understand the topic), i just realized that too much nested (grouped) layers rasterize filled shapes.
Release and rearrange the  back/front rasterized shape's leayer and the problem go away.
my 2c (and my bad english, sorry ;))

 

Edited by ruez
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.