Jump to content

Dick Sites

Members
  • Content count

    3
  • Joined

  • Last visited

  1. Dick Sites

    Several bugs displayng SVG input

    Thanks, Walt. One of the portions that I expected to be in a serif font is here, with no mention of sans-serif: <text id="titletext" transform="translate(802.5, 44)" font-size="50px" class="title-text noselect" style="display:block;font-size:50px;height:auto;overflow-x:visible;overflow-y:visible;white-space:nowrap;width:auto;perspective-origin:0px 0px;transform:matrix(1, 0, 0, 1, 802.5, 44);transform-origin:0px 0px;user-select:none;fill:rgb(0, 0, 255);text-anchor:middle;">Hello World ssh</text> I will add an explicit font-family="serif" in my original. I have also worked around the rgba display error in inkscape and others by switching to rgb and an explicit opacity=0.5 or whatever. 6) I think there is still a clipping issue in Affinity (and inkscape), not seen in the original file, but seen in the attached svgtop(6).svg file. The black horizontal lines headed off the the left edge should be clipped at the left of the main white area, as seen when opening this file in a browser. Possibly related to nested svg regions, but apparently only clipping to the outermost one. There should also be a light yellow background outside the main white area: see a browser display of this. /dick svgtop (6).svg
  2. Dick Sites

    Several bugs displayng SVG input

    I generated it from my hand-coded HTML file that sets up the overall SVG structure and then dynamically generates all the SVG timelines (showing the *complete* CPU execution of the hello world program). I exported the dynamically-created DOM from the Chrome browser via the "svg crowbar2" extension. So 1 and 2 are bugs, and I believe 3 might be a bug since the browser defaults to a serif font, but Affinity shows sans-serif. 4 and 5 are not Affinity bugs. Thanks, /dick
  3. Dick Sites

    Several bugs displayng SVG input

    Several bugs of Affinity Designer 1.6.0 displaying the attached SVG. Compare to viewing the same file in Chrome or Safari (Firefox mangles the fonts, inkscape turns rgba into solid black) 1) Black text on left should be to the left of leftmost vertical black line (negative width, right-justified) 2) Vertical gridlines above X-axis ticks should be very light gray, not black 3) Top Hello... and bottom Time... blue text should be a serif font 4) Black-text fonts are a little too high and wide vs. default browser sans-serif font (Arial, I presume) 5) Unicode characters at lower right are not properly displayed -- circle 1 thru circle 5 plus up-down arrow svgtop (4).svg
×