Jump to content

jimlewis

Members
  • Content count

    2
  • Joined

  • Last visited

  1. jimlewis

    Photo persona not working

    Thanks. I understand.
  2. When I click on Photo Pesona, I get the following message: "A compatible version of Affinity Photo is required." I purchased Affinity three months ago through the AppStore. Is this the explanation for the error message?
×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.