Jump to content

joed1035

Members
  • Content Count

    3
  • Joined

  • Last visited

  1. Thank you all for your help. I will keep the current encodings in mind and wait for the hyphen encoding fix or a setting change and the original name added as an attribute.
  2. I name all of my layers and groups in my SVG file. It is crucial the IDs export correctly so I can target them with ease in CSS and Javascript. The recent update just messed up how they export. Normally name of layer: dismiss-popup as typed (see attachment) Would appear as such on export in SVG code: <g id="dismiss-popup"><rect x="-36.697" /* rest of SVG code */ After update, it does this: <g id="dismiss.-popup"><rect x="-36.697" /* rest of SVG code */ What is with the period?! Now I have to go through and edit the IDs or CSS/JS code every time I modify my SVG interactive and export it. I guess I could just accept the periods, but I would like to know why it is doing it. Is this a bug or my machine? Why was this done? Thanks
  3. I searched the forums extensively for this but couldn't find any information. I am sorry if I missed it. I would like to give classes to the shapes I create for export or IDs. Either one would work. For example, I have many objects within different groups called screen. Even though they are in different groups with different names, I notice when I export it consecutively names them so no two are the same. The first path with name will have ID id="screen", the second id="screen1", third id="screen2", id="screen3", and so forth. Basically, how can I customize this or make the IDs the same?
×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.