Jump to content
Filter Forge

Filter Forge doesn't work under latest versions of Affinity Photo

Recommended Posts

Yes, I'm Jane from Filter Forge and I'm here to ask for help.  We want to make Filter Forge work under all the versions of AP (both Windows and Mac) but we need help from the Serif developers. Unfortunately, the guy who helped us previously ceased to answer my messages and I think he doesn't work in Serif anymore. 

Hey, people,  who want Filter Forge work correctly with the latest Affinity Photo, comment here and describe your problem.

Hey, Serif guys, let us work together and make people happy. 

 

Thanks,

call me Jane.

Share this post


Link to post
Share on other sites

@Filter Forge & @Mark Ingram Thank you for being pro active on keeping filter forge working, much appreciated.


iMac 27" Late 2015 Fully Loaded, iMac 27" Mid 2011 both running High Sierra 10.13.6 - Affinity Designer/Photo & Publisher - Illustrator CC, Inkscape, Blender, Sketchup, Pepakura Designer, MTC, Pixelmator & Pixelmator Pro + more... XP-Pen Artist-22E, - iPad Pro 12.9 B|  

Affinity Help - Affinity Desktop Tutorials - Feedback - FAQ - most asked questions

Share this post


Link to post
Share on other sites

Filter Forge 9 does work *sort of* with Affinity Photo 1.7.3, but with these limitations:

When you use a filter (that has the Diffuse, Bump, Normal channels active but NOT channels like Ambient Occlusion.) and you activate a channel that is normally not active in a filter and apply the filter to send back to Affinity Photo, Affinity just sits there completely locked up doing nothing. Only entering Task Manager and killing the process will allow you get control back.
A workaround would be to run FF9 as a standalone, but FF9 only allows you to create a bitmap of 600 x 600.

Secondly Affintiy Photo 1.7.3 only activated filters on a new document if you first fill the new empty document with a pixel layer like white...other wise all filters remain greyed out.

Share this post


Link to post
Share on other sites

FF9 can do bitmaps larger than 600x600 just go to File > New Image... and type the size you want, I regularly create textures @ 2000x2000px

https://www.filterforge.com/more/help/MainWindow/NewImage.html

Quote

Width, pixels – Specifies the image width. The width cannot exceed 3000 pixels in the Basic and Standard editions of Filter Forge, and 65536 pixels in the Professional edition. See Filter Forge Editions for more information.

Height, pixels – Specifies the image height. The height cannot exceed 3000 pixels in the Basic and Standard editions of Filter Forge, and 65536 pixels in the Professional edition. See Filter Forge Editions for more information.

Fill Color – Defines the color to fill the image. The color supports transparency (alpha channel).

Note that when you preview or apply an effect filter to a solid-colored image, the results may not be visible. If you plan to work with effect filters, you can open a source image via the File > Open Image or File > Built-In Preview Images command in the Main Window menu.

 


iMac 27" Late 2015 Fully Loaded, iMac 27" Mid 2011 both running High Sierra 10.13.6 - Affinity Designer/Photo & Publisher - Illustrator CC, Inkscape, Blender, Sketchup, Pepakura Designer, MTC, Pixelmator & Pixelmator Pro + more... XP-Pen Artist-22E, - iPad Pro 12.9 B|  

Affinity Help - Affinity Desktop Tutorials - Feedback - FAQ - most asked questions

Share this post


Link to post
Share on other sites

Hi Hamfast,

Thanks for the detailed report. I'll pass your message to our tester and we'll try to find out what's wrong.

I hope that it will be something where we can help, but there's a couple of known issues that we're fixing right now with Affinity developers. They say that the fixes will be released along with the official AP 1.8 release. 

Best regards,

Jane

Share this post


Link to post
Share on other sites
On 1/14/2020 at 1:47 PM, Hamfast said:

When you use a filter (that has the Diffuse, Bump, Normal channels active but NOT channels like Ambient Occlusion.) and you activate a channel that is normally not active in a filter and apply the filter to send back to Affinity Photo, Affinity just sits there completely locked up doing nothing. Only entering Task Manager and killing the process will allow you get control back.

Can you please specify what filter exactly caused the AP freeze? We tried to reproduce the problem but everything worked. The problem could have originated from the fact that since AP 1.5 Filter Forge doesn't have a progress bar. So when it renders large bitmaps or complex filters or both it can be slow. Without a progress bar, the rendering process looks like AP froze.

 

On 1/14/2020 at 1:47 PM, Hamfast said:

Secondly Affintiy Photo 1.7.3 only activated filters on a new document if you first fill the new empty document with a pixel layer like white...other wise all filters remain greyed out.

This case is even more mysterious. Because AP and FF should behave completely the opposite way. When you create a new document in AP there's completely nothing there (compare with PS, where a new document has a default background layer). So filters should be greyed out cause they have nothing to render yet. When you draw anything or paste an image the filters become active -- they have a raster image to deal with. 

Can you please describe what is going on more precisely? 

Share this post


Link to post
Share on other sites

Just to clarify if you add an image to a file and it comes in as an image layer it must be rasterised before the filters become active.


iMac 27" Late 2015 Fully Loaded, iMac 27" Mid 2011 both running High Sierra 10.13.6 - Affinity Designer/Photo & Publisher - Illustrator CC, Inkscape, Blender, Sketchup, Pepakura Designer, MTC, Pixelmator & Pixelmator Pro + more... XP-Pen Artist-22E, - iPad Pro 12.9 B|  

Affinity Help - Affinity Desktop Tutorials - Feedback - FAQ - most asked questions

Share this post


Link to post
Share on other sites

image layer IS usually a raster image, but it is just packaged as "smart layer" which may prevent some operations like accessing FF.

Share this post


Link to post
Share on other sites

Just purchased latest Affinity Photo yesterday.  Seems Filter Forge 8 does not work with this program , neither do most of my other plug-ins, which all work with my other photo editing  software.  I keep getting same error message each time I attempt to use it : <class XFW::StateError> The control <class Controls::Control>@0000000000CFEE50 has no window handle.  This is upsetting as I use Filter Forge 'a lot' for my art and to enhance my photos.  Anyone know of a solution. I have contacted Filter Forge, still awaiting a response.  The other plug-in will not even show up on the list,, even though I've added them to the lists. Without the Plug-In, Affinity is really not useful for me.

Edited by mdboo123
added addtional note

Share this post


Link to post
Share on other sites
On 1/30/2020 at 5:15 PM, mdboo123 said:

Just purchased latest Affinity Photo yesterday.  Seems Filter Forge 8 does not work with this program , neither do most of my other plug-ins, which all work with my other photo editing  software.  I keep getting same error message each time I attempt to use it : <class XFW::StateError> The control <class Controls::Control>@0000000000CFEE50 has no window handle.  This is upsetting as I use Filter Forge 'a lot' for my art and to enhance my photos.  Anyone know of a solution. I have contacted Filter Forge, still awaiting a response.  The other plug-in will not even show up on the list,, even though I've added them to the lists. Without the Plug-In, Affinity is really not useful for me.

Hi, @mdboo123, the "handle" error means that FF does not officially support the latest version of AP. We're trying to fix this with @Mark Ingram . Meanwhile you can try to install FF manually.

Instructions for Mac version 


And for Windows

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.