Jump to content
mykee

No Hyphenation in last line/word of column

Recommended Posts

Dear developers,

Please add an option to hyphenation: No hyphenation in last line/word of column. I'm a book wrapper too, and hypenation zone and column zone not helped. If can add this option, then last line or word of column will not wrapped.

This will great help when I wrapping a book. Thanks!

Share this post


Link to post
Share on other sites

Possible workarounds for you:

  1. Press Tab after the last word.
  2. Insert a soft-hyphen at the end of the last word.
  3. Apply a Character Style to the last word with the "No Break" option set.

-- Walt

Windows 10 Home, version 1903 (18362.356), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.3.481 and 1.8.0.486 Beta   / Affinity Designer 1.7.3.481 and 1.8.0.486 Beta  / Affinity Publisher 1.7.3.481 and 1.8.0.499 Beta

Share this post


Link to post
Share on other sites

Ok, I use "No Break" option, but if I not see a hyphened word, then book wrapping will wrong. Your tips is greats, but manually.

I need automatic feature for last word/line of column. Just check, and program will not hyphen there.

Share this post


Link to post
Share on other sites

The feature I think you are asking for should already be covered by the Column End Zone. That should prevent hyphenation at the end of the last line of a column, if you set it to a suitably large value. You can use several inches if you don't mind very long words being pushed to the next column. I just tried it in 1.7.3 and it seemed to work. You say it doesn't work for you. What did you try, and what happened?

Share this post


Link to post
Share on other sites

@Dave Harris I used this option, but no helped: if this value too big, many lines will drop to next page, no word only. And I use a few millimeters only (I no use inches), then many places release hyphened words. :( I think what you suggested: this option change this parameter, but often no helped :( I set this parameter to 7 mm, but I need correct manually many times.

 I need set word length in millimeter? It would be easier a setting for "last word of column is no break" or any similar.

 

OK, here is what's my problem with Column End Zone. Here is a hyphenation with 20mm settings:

hyph20mm.thumb.jpg.cc756137ef26ae9eb744d52d355156a5.jpg

 

And I changed this parameter to 285mm (longest hungarian word is 67 character = 283,633512‬mm):

hyph285mm.thumb.jpg.3387f49bb045b01b51f5b22becb96747.jpg

 

And last paragraph jump to next page! Not only last word... Page size is 130x197, and margins 20-20mm on left and right side. I don't know what is good parameter for Column End Zone for last word no wrapping...

Update: I set to (130mm - 2x20mm - 10mm) 80mm this zone, and I checking where working or not.

Share this post


Link to post
Share on other sites

Mykee, sorry for not getting back to you quicker. Setting the zone to 285mm should work fine. I've not been able to reproduce the behaviour where it moves the entire line or paragraph to the next page. Is it possible there were some other settings, such as Keep together or Prevent orphaned last lines involved?

Can you attach a small sample document which show it going wrong, so I can examine what is happening?

Share this post


Link to post
Share on other sites

@Dave Harris Here is a sample from this project and I use Prevent orphaned last lines, because need this option for book wrapping (Keep together option not):

https://1drv.ms/u/s!Ar9GB-v89284gf5_rpJNw9hOBR8VPg?e=SMWYDR

You need install hungarian hyphenation too before open sample project, package include this.

And in this topic talk with this bug (or feature), where you find source word file too:

 

Share this post


Link to post
Share on other sites

OK, there is a bug in the interaction between Column end zone and Prevent orphaned first lines and Prevent widowed last lines that can cause it to move an extra line. Because there are several paragraphs of two and three lines, that bug ends up causing the large gap.

If all three options are off, the word "hangon" is hyphenated at the end of a column. If Column end zone is then set to 80mm, that word is moved to the next column, which is correct. However, that leaves the last line of the paragraph as a widow at the top of the next column. If Prevent widowed last lines is switched on for that paragraph, it should move one line from the previous paragraph. It actually moves two. That makes a new widow, so if Prevent widowed last lines is switched on for the paragraph that moved, two lines are brought forward. That makes an orphaned first line, so switching on the option to control those moves a third line forward.

The bug should be fixed in 1.8 (although it may not make the next beta). Thanks for reporting it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.