Jump to content
jfcartier

Renaming Layer unfocuses without reason

Recommended Posts

So, this problem have been around for quite some time, (since at least v1.6 I believe).
When you rename an Artboard, it sometimes unfocuses the label field for no specific reason (as if there was a loop somewhere that ends the edit process, idk).
Sometimes it just unfocuses, sometimes it also deletes it's content to keep the first letter only.
Do you have and idea why it does that? Thanks

Share this post


Link to post
Share on other sites

Hi jfcartier,

This is a known issue that is with development and seems to be related to the speed at which you double click. I understand that these actions are muscle memory, however if you can try and slow the double click speed down you should be able to rename. 

I'll get it bumped with development though!
 

Share this post


Link to post
Share on other sites

@Sean P Thanks for the reply!

For those who lives the same, I manage to make it work-ish when I double click then use the arrow keys to "trigger" the problem (see video).
With arrow keys, it won't end the edit mode, so I can edit the layer.

I would agree it's a small problem, but as many, we need to do this, like every minute. At the end of the day, it's a bit annoying and impact the productivity.
Thanks again!

Share this post


Link to post
Share on other sites

You'll be either happy to know (you aren't crazy!) or saddened to know (Affinity has known about this for years and done nothing) that this bug has existed since even before I made a thread about it back in 2017. It *seems* like a small bug, but after a late night of designing it ends up frustrating me so much that I have vowed to not use this program any more for large scale design tasks, period. The inability to simply make a new layer, and double click it to rename it such a basic and essential failure that over the course of creating 200+, 300+ layers I just can't take it.

 

What's interesting is seeing the reply in this thread from staff that not only acknowledges that it's an old problem, but also acknowledges that they know exactly what causes it and the solution from their end is "try clicking slower?". I can't, for the life of me, begin to comprehend what kind of deep-rooted bug exists in their software that simply clicking too fast warps the UX the way it does. But, oh well.

Share this post


Link to post
Share on other sites

This is actually a traditional Mac behavior with file names under Finder icons also.  A fast double-click on the name is the same as on the icon and opens the file/folder, while clicking once to select, then delaying and clicking again allows you to rename.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.