Jump to content

Recommended Posts

Dear forum, dear support team,

I had upgraded the long path from Windows 7 to Windows 8.1 (each update had to be installed for 7, then upgrade to Win8, then install each update, then upgrade to 8.1, then install each update (took 3 days to complete))
As I found out later, everything survived, EVEN the installed applications, but NOT %windir%\installer, where all the setup files are stored, weirdly.

I did, however, finally fire up Affinity Designer and got informed that there is an update available. Of course I went and get it (same for Affinity Photo).
Next, I did right click on the setup exe, executed that one as Admin and it said right away "upgrade to 1.7.x". - I clicked that button as well, and in the very next dialog it said "an error occured". I had only one choise to click on "exit".

Cool. What now?

I tried to manually deinstall the product (file system and registry), but no luck. It still claims to be installed. Also right clicking the msi file, contained in the setup exe, didn't bring me any further, as this one can only maintain already installed products, which... it said, is not the case.

There is, however, a set of log files created by setup.
in my %temp% folder:
MSIc238.LOG: "Das System kann das angegebene Gerät oder die angegebene Datei nicht öffnen." (System cannot open the device or file)

in %temp%\AffinitySetup\58b13cae-e824-11e9-be93-74d435864182:
Setup.log:
-----------------------------------------------------
Trying to start process: T:\TEMP\AffinitySetup\58b13cae-e824-11e9-be93-74d435864182\SetupUI.exe /log=true
  Succeeded: 1
Waiting for process to finish...
  Exit code: 0
-----------------------------------------------------

SetupUI.log:
-----------------------------------------------------
+Startup: 06.10.2019 12:30:43
+OS version: 6.3.9600
+ProductName: Photo
+ProductType: Retail
+Opening HKLM...
+    OK
+Opening registry key: 'SOFTWARE\Serif\Affinity\Photo\1'...
+    Failed
+Getting ProgramW6432 environment variable...
+    OK
+Install path not found, using default: C:\Program Files\Affinity\Photo
+Opening MSI database: Affinity.msi
+Opening database view: SELECT `Value` FROM `Property` WHERE `Property`='ProductVersion'
+    OK
+MsiViewExecute
+    OK
+MsiViewFetch
+    OK
+MsiRecordGetString
+    Value: 1.7.3.481
+Opening database view: SELECT `Value` FROM `Property` WHERE `Property`='ProductCode'
+    OK
+MsiViewExecute
+    OK
+MsiViewFetch
+    OK
+MsiRecordGetString
+    Value: {6EE06075-1F8E-4737-B744-B2BB8E2BFE28}
+Install state: -1
+    IsThisVersionInstalled: False
+Opening database view: SELECT `Value` FROM `Property` WHERE `Property`='UpgradeCode'
+    OK
+MsiViewExecute
+    OK
+MsiViewFetch
+    OK
+MsiRecordGetString
+    Value: {21399BDD-4C2C-4565-9426-410BDC894DA7}
+MsiEnumRelatedProducts: SUCCESS
+    IsAnyVersionInstalled: True
+        Current product code: {F3F25644-68DE-4EF1-9DCA-F2F9821A9B3E}
+ProductCode: {6EE06075-1F8E-4737-B744-B2BB8E2BFE28}
+ProductVersion: 1.7.3
+InstallType: Update
+Initialising main window...
+    OK
+Main window loaded
+Checking requirements...
+    OK
+DotNetInstall: checking installed version
+    Found 528049
+Switching to page: Update
+Creating InstallOperation
+    Path: C:\Program Files\Affinity\Photo
+    WantShortcut: True
+Requesting operation: SetupUI.InstallOperation
+Switching to page: Operation
+Starting MsiOperation
+Error: Das System kann das angegebene Gerät oder die angegebene Datei nicht öffnen.
+Setting result page message: Fehler beim Setup
+Switching to page: Result
+Operation finished
+Main window close requested
-----------------------------------------------------

So.. apparently it somehow still claims the product is installed, even though it is not anymore.

--> How can I overcome this situation? Is there a registry key to delete/change, a file to alter or some switch to flip? I would like to install the new version. Currently I have none installed as the tool does not let me install it anymore >_<'.

Kind regards,
Mathias

Share this post


Link to post
Share on other sites
If you're getting an error when installing our app/update, please read the following thread on our support forum ( https://forum.affinity.serif.com/index.php?/topic/64511-windows-installation-issues-faq/  ) for more information. However, if you're getting a Setup Failed error or the Installer Window UI isn't displaying correctly, please read the appropriate instructions below.
 
// Setup Failed Error
 
If you’re getting an error ‘Setup Failed’ when trying to install our app/update, please try the below suggestions. They should hopefully allow you to install our app/update without any further issues:
 
⁃Restart your machine and try the installation again
⁃Right click the .exe file and select ‘Run as Administrator’
⁃Make sure your machine isn't in the middle of installing updates - this can lock files needed to install our app/update
⁃Make sure your machine is fully updated by checking for any available updates
⁃If you’re using an app, such as ImDisk, to modify where your TEMP directory is stored, please disable this and use the default Windows TEMP directory.
 
// Installer Window UI Issues
 
If you’re not getting ‘Setup Failed’ when installing our app/update you could be experiencing one of the below issues:
 
⁃If you’re not seeing the installer Window UI at all, please read this thread on our Support Forum for more information: https://forum.affinity.serif.com/index.php?/topic/67113-issue-of-install/
⁃If you’re seeing the Installer Windows UI but it only shows the App’s name, please download and install the latest versions of the Windows .NET Framework from here: https://dotnet.microsoft.com/download/dotnet-framework
 
If you’ve tried all of the above and you’re still having issues, please send us your Setup log files. This will allow us to look into this further for you.You can access the setup log files by navigating to %TEMP%\AffinitySetup\ from the Run Dialog. You will want the folder with the latest Created/Modified Date. In this folder you will have two .log files: Setup.log & SetupUI.log.

Share this post


Link to post
Share on other sites

Dear DWright,

everything: checked.

Trying around with MSIEXEC I found out, the stuff can neither be repaired/uninstalled, but INSTALLED, but only when you copy the MSI file over to %windir%\Installer.

So.. the solution, for me, is:
1) Execute setup
2) switch over to your %temp% folder, copy over the msi file from the Affinity setup directory to %windir%\Installer
3) close setup (optional: delete everything from Affinity in %temp% afterwards)
4) navigate to %windir%\Installer, right click the MSI file --> click on install in the context menu (setup will run through normally, making another copy of the msi file INSIDE of %windir%\Installer)
5) delete the msi file that YOU have copied over to %windir%\Installer (setup has copied that one for later reference, so the original can go)

--> works for me. *happy*

Thank you for the heads up. : )

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.