Jump to content

Recommended Posts

can't figure this out, something is wrong but i don't no what.

Subtracting.png.5de5cfba09c6aa624cca8d62b7bf901e.png


intel core i5,  16GB 128Gb ssd win10 Pro Huion new 1060plus.

philips 272p 2560x1440px on intel HD2500 onboard graphics

Razer Tartarus Chroma

Share this post


Link to post
Share on other sites

Select A and B >geometry Add(becomes one curves object)
Now select both the new curves object and the rectangle geometry>subtract


-------------------------------------------------------------------------------------------------------------------------------
Win10(1909)Home / Photo / Designer / Publisher & latest (beta) versions

Share this post


Link to post
Share on other sites

When i select a and b and subtract it becomes 1 curves object.


intel core i5,  16GB 128Gb ssd win10 Pro Huion new 1060plus.

philips 272p 2560x1440px on intel HD2500 onboard graphics

Razer Tartarus Chroma

Share this post


Link to post
Share on other sites

Maybe drag the B rectangle from the curve first(layers panel) may do the trick.
Select A and B >geometry Add(becomes one curves object)
Now select both the new curves object and the rectangle geometry>Subtract


-------------------------------------------------------------------------------------------------------------------------------
Win10(1909)Home / Photo / Designer / Publisher & latest (beta) versions

Share this post


Link to post
Share on other sites

But when i remove rectangle a and make rectangle b little wider and do a subtract it won't subtract, so there is something wrong in the file.

 


intel core i5,  16GB 128Gb ssd win10 Pro Huion new 1060plus.

philips 272p 2560x1440px on intel HD2500 onboard graphics

Razer Tartarus Chroma

Share this post


Link to post
Share on other sites

That's what I think so I created another file with the original Problem (1) and added another set of rectangles to test the subtracting with new shapes (2 and 3) and as you can see it worked. One thing I have noticed and that the edges of the two rectangles must be exactly in line with each other in order for Subtract to work.

Subtracting 2.afdesign


Mac OS X El Capitan Version 10.11.6

AD version 1.6.0

Share this post


Link to post
Share on other sites
4 minutes ago, Wosven said:

Yes, one of the curves is bugged, creating new rectangles and substracting work fine.

Is this a bug reporting issue?


Mac OS X El Capitan Version 10.11.6

AD version 1.6.0

Share this post


Link to post
Share on other sites

Tried it with your file in both beta and release and works just like expected.

Subtract.thumb.gif.134295ae356f7275eeea33eb026fd7cf.gif


-------------------------------------------------------------------------------------------------------------------------------
Win10(1909)Home / Photo / Designer / Publisher & latest (beta) versions

Share this post


Link to post
Share on other sites

But if you try to select B from the main curve, it wont. Addind A to B "cured" the curve.

If I create a new rectangle (on the same side above B) and substract it from the main curve, I've got the same problem as with substracting B. If I create a new one on the A side, it'll be substracted correctly.

Share this post


Link to post
Share on other sites
8 minutes ago, haakoo said:

Tried it with your file in both beta and release and works just like expected.

 

But what happens if you delete the white rectangle first


intel core i5,  16GB 128Gb ssd win10 Pro Huion new 1060plus.

philips 272p 2560x1440px on intel HD2500 onboard graphics

Razer Tartarus Chroma

Share this post


Link to post
Share on other sites

There is a something done before the A subtraction
Try dragging the A rectangle and you'll see the subtraction already occurred but there's a leftover shape??

But at least its solved :)


-------------------------------------------------------------------------------------------------------------------------------
Win10(1909)Home / Photo / Designer / Publisher & latest (beta) versions

Share this post


Link to post
Share on other sites
7 minutes ago, Wosven said:

But if you try to select B from the main curve, it wont. Addind A to B "cured" the curve.

If I create a new rectangle (on the same side above B) and substract it from the main curve, I've got the same problem as with substracting B. If I create a new one on the A side, it'll be substracted correctly.

That's what I discovered.


Mac OS X El Capitan Version 10.11.6

AD version 1.6.0

Share this post


Link to post
Share on other sites
1 minute ago, haakoo said:

There is a handling done before the A subtraction??
Try dragging the A rectangle and you'll see the subtraction already occurred but there's leftover shape??

Thats what i did and now subtract won't work on the right side


intel core i5,  16GB 128Gb ssd win10 Pro Huion new 1060plus.

philips 272p 2560x1440px on intel HD2500 onboard graphics

Razer Tartarus Chroma

Share this post


Link to post
Share on other sites

The A rectangle is probably a compound object of some sorts


-------------------------------------------------------------------------------------------------------------------------------
Win10(1909)Home / Photo / Designer / Publisher & latest (beta) versions

Share this post


Link to post
Share on other sites

I'm finding all these explanations quite confusing! All I wanted to do was to subtract A and B rectangles from the large rectangle. I have since done this successfully but by using three new rectangles. At some point in my original drawing something odd crept in and created this problem. Trying to understand why it wasn't working got out of hand so I've just redrawn it so I can proceed.

Thanks for all your efforts.


Mac OS X El Capitan Version 10.11.6

AD version 1.6.0

Share this post


Link to post
Share on other sites
5 minutes ago, haakoo said:

The A rectangle is probably a compound object of some sorts

I had a suspicion that may have been the case but I wasn't able to work out how to 'Undo it'.


Mac OS X El Capitan Version 10.11.6

AD version 1.6.0

Share this post


Link to post
Share on other sites
37 minutes ago, jackamus said:

Is this a bug reporting issue?

If you can remember and reproduce the steps to bug a curve yes, but it looks more like a bugged file. Perhaps Serif will be able to look at your file and understand where it come from.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.