Jump to content
Sign in to follow this  
billtils

Quick Mask not working

Recommended Posts

Encouraged by the recently posted set of new videos on the AP Vimeo channel, I decided to try some new tricks.  First up was Quick Mask.  I was happy with using the selection tool but this looked worth a go.

 

It doesn't work.  Toggling QM brought up the red overlay, but the painting step doe not work.  Hovering the brush does not give a preview and painting does nothing.  "Edit selection as a layer" is active. 

 

Found the answer:  you have to select White as the paint colour.  This is not specified in the video - time for an edit!!!


Retina iMac (4K display, 1TB SSD, 16GB RAM) OS X 10.11.6  Capture One 10.

 

Share this post


Link to post
Share on other sites

Hi there, looks like you got a sneak preview of the release videos! Sorry about that, looks like Vimeo displays videos in a channel even when they're set to private. We've removed them for now.

 

Thank you for the feedback, the brush colour was already set to white when I recorded the quick masking, probably from a previous session. I will correct this for release.

 

We'll be launching with a comprehensive set of videos for Photo, and there are more coming for post release. Requests welcome!


Product Expert (Affinity Photo) & Product Expert Team Leader

@JamesR_Affinity for tutorial sneak peeks and more

Share this post


Link to post
Share on other sites

Thanks James.  Sounds good!


Retina iMac (4K display, 1TB SSD, 16GB RAM) OS X 10.11.6  Capture One 10.

 

Share this post


Link to post
Share on other sites

I think well-done videos can be especially effective in showing how to use Photo. The best examples I've seen of effective teaching videos are for Capture One Pro 8, on Youtube. Well written and well produced. Easy and clear.

 

https://www.youtube.com/playlist?list=PLDMRz3ssFQH6eHHX5Pw2Lf0DO8UB5siyH

 

My requests for videos:

 

selection: comprehensive, using all selection tools, Quick Mask, refine edge, relation of selections to vector shapes

 

masking: comprehensive, including Spare Channels, manipulating masks in layer view,

 

color: comprehensive, including picking color, creating swatches, assigning color to objects

 

Thanks for your efforts and your atttention,

 

Kearney

Share this post


Link to post
Share on other sites

I also tried to figure out what it was i did wrong.

 

Then i found this thread and read about selecting white as color. I still get stuck after adding a layer. I see the blinking lines around the object i 'painted', and after that add a new adjustment layer -> HSL adjustment. Then a window pops up where i can adjust the HSL. But nothing happens at the parts i 'painted' earlier....  :huh:


newbie on Affinity Photo

Share this post


Link to post
Share on other sites

Thank you @MEB

 

It was exactly that video tutorial i was trying to reproduce in one photo. I just tried the same tut in another photo and then id did work for me. So i did overlook something or did something wrong...

 

Sometimes i still have troubles getting a filter working after making a selection. I think i have to try more often  :)

 

Thanks for your tip about the Help menu section - i didn't even look that one up yet  B)

 

(also i see now i'm in beta section of the forum, but i'm working with the bought version from the Mac App Store) 

Edited by peterbakker

newbie on Affinity Photo

Share this post


Link to post
Share on other sites

This is very bizarre I came here looking for the correct answer to this problem but no one answered it.  I have followed the EXACT instruction on the vimeo tut but still I can not get the mask.  Is there anyone who will address this in detail?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.