Jump to content
olibclarke

"plus" sign does not obey superscript typography

Recommended Posts

Super weird. I highlight a plus sign, and select superscript in typography, but the plus sign is not superscript-ed? This used to work, I'm not sure when it broke?

Also another weirdness with superscript - if I change the typography to superscript with no text selected, it randomly superscripts certain characters in the middle of a word for no apparent reason. Very bizarre. I'm using 1.7.2 on Mac.

Here is a screen recording: https://www.dropbox.com/s/g7kb6p12rybzzww/superscript_bug.mov?dl=0

The different superscript function in positioning/transform seems to work fine. I'm not sure why there are two? Perhaps I'm missing something and this is not a bug after all, but it is definitely not the behavior I would expect.

Cheers

Oli

 

Share this post


Link to post
Share on other sites

You may be thinking of Designer 1.6, where Designer was happy to provide faux super- and subscripts for any characters where the font didn't provide true support.

In 1.7 Designer acquired the Typography support from Publisher which is more sophisticated. With the new support the super- and subscript options in Typography apply only when the current font provides support for those characters.

If you have a character that does not have true super- or subscript in your font, the Typography options will be ignored. You can manually choose to use faux super- or subscripts using the Positioning and Transform section of the Character panel, via the field with the label that looks like "S:" on the bottom right of that section.

Share this post


Link to post
Share on other sites
On 9/28/2019 at 10:27 PM, walt.farrell said:

You may be thinking of Designer 1.6, where Designer was happy to provide faux super- and subscripts for any characters where the font didn't provide true support.

In 1.7 Designer acquired the Typography support from Publisher which is more sophisticated. With the new support the super- and subscript options in Typography apply only when the current font provides support for those characters.

If you have a character that does not have true super- or subscript in your font, the Typography options will be ignored. You can manually choose to use faux super- or subscripts using the Positioning and Transform section of the Character panel, via the field with the label that looks like "S:" on the bottom right of that section.

Just to echo that Walt is correct, we added support for true typographical sub/super script characters in 1.7, and moved the faux support to the S: dropdown on the Character Panel.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.