Jump to content
HarryMcGovern

Designer not showing px when selected

Recommended Posts

This may be my fault but when I change a brush to px from pt, which seems to be a default, in brush or pen modes especially. May be others, the display in the size stays at pt, and doesn’t change to px.  So, in the image attached the 5px as selected remains 2.5pt when I press ok.


I’m using the latest iPad version by the way. Is this an issue? Or am I doing something wrong?

AEA6F5FB-3245-4260-89AD-69AC49E69E70.thumb.jpeg.1c144d3a6ccd26d3e0d336efda4c8ed7.jpeg

Share this post


Link to post
Share on other sites

Hi HarryMcGovern,

This is working as expected.  I suspect you have your document set use Points and this is being applied to stroke units (which is what strokes normally use).  If you start a new document and on the new document options,  set the units to pixels.  This would then show this option in Pixels

Having said that, even tho you typed in 5 pixels and it then shows as 2.5 points, unless i'm mistaken, that is the correct conversion from pixels to points. So despite what you are seeing, it is a 5 pixel stroke :) 

Hope i've explained that well enough, but any questions please do ask :) 

Share this post


Link to post
Share on other sites
20 hours ago, stokerg said:

Hi HarryMcGovern,

This is working as expected.  I suspect you have your document set use Points and this is being applied to stroke units (which is what strokes normally use).  If you start a new document and on the new document options,  set the units to pixels.  This would then show this option in Pixels

Having said that, even tho you typed in 5 pixels and it then shows as 2.5 points, unless i'm mistaken, that is the correct conversion from pixels to points. So despite what you are seeing, it is a 5 pixel stroke :) 

Hope i've explained that well enough, but any questions please do ask :) 

Thanks, yes the document does read px but the behavior in document remains the same. No matter what option I use, it still reverts to pt, not px.

Now it’s all very well setting defaults to points, but if I want or need to work with pixels, px, and I’ve set the document defaults to px, then it should stay px.

its confusing having it revert.

I might add, that any pen etc that I try to set to px, steadfastly remains pt. Doesn’t matter what. in remains pt and so on.

i mean. If I set a pen to px, it should read px.?

 

 

 

Share this post


Link to post
Share on other sites

Go to the home screen, tap on the Preferences gearwheel and go to the Interface page. Toggle ‘Lines in points’ on or off, as desired.


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.3.481 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.7.3.155 • Designer for iPad 1.7.3.1 • iPadOS 13.2.2 (iPad Air 2)

Share this post


Link to post
Share on other sites
6 minutes ago, HarryMcGovern said:

Switching off both options sets the line width etc to px by default.

Both options? Do you mean ‘Text in points’ and ‘Lines in points’? :/ Unless I’m missing something, only the latter is relevant to the present discussion.

6 minutes ago, HarryMcGovern said:

Fine but then on screen display stays as px no matter what you select in the document options.

When I tried to change the units just now to reproduce that here, the app crashed. :(


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.3.481 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.7.3.155 • Designer for iPad 1.7.3.1 • iPadOS 13.2.2 (iPad Air 2)

Share this post


Link to post
Share on other sites

Regardless, both options on, one on one off, one off one on, it simply doesn’t behave as it should.

If I set a line to a width in px, it should show that setting in the display.

if I set a line to a width in pt, it should show that setting in the display.

The gearwheel setting of the on/off options appears to affect only the document size settings. It also affects the line size display.

It also affects the size display of text sizes.

The thing is, if I set a pen line width to be 5px I expect to see that displayed in the interface as 5px, not 1pt, or what ever it is. And vice versa.

In short, there is something wrong with this paradigm.

I’m not complaining, I understand where 1st release software comes from. I hope it’s not a ‘feature’ though.

So hopefully it’s something that will be looked at. It’s pointless allowing the user to set any measurement type from the list of options, when once accepted it simply displays what it wants.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.