Jump to content
dtpunger

Automatic reformatting

Recommended Posts

When I open again a set page with text wrapping around an image, Publisher has automatically reformatted the text, ignoring hyphenation and leaving ugly gaps between the words.

Bildschirmfoto 2019-09-25 um 09.45.01.png

Share this post


Link to post
Share on other sites

> automatically reformatted the text

It is natural that the text runs different if it has different space (less column width). But where do in the red marked spots the hyphenation – symbols come from? Are they typed into the text as visible characters? Then you need to delete them because they are not necessary any more with the new text flow.

> ugly gaps between the words.

Also this is related to your change of available space for the text by adding the image to wrap. To avoid those gaps you need to adjust your hyphenation settings (or activate it at all in case you typed all visible hyphens manually).

 


macOS 10.12.6,  Macbook Pro 15" + Eizo 24"

Share this post


Link to post
Share on other sites

I don't use Publisher's automatic hyphenation and place the hyphens manually (red underlined). Thus I assume the destruction of my typography is an issue of the app.

Share this post


Link to post
Share on other sites

> Thus I assume the destruction of my typography is an issue of the app.


It is rather vice versa. The app did what you initiated:

1. you type a – symbol as a visually hyphen at the edge of the text frame,
2. then you change the column width (frame width) by placing an object and demand the text to wrap that object.
3. Therefore the app moves the letters according to the remaining space as demanded.
4. Your manually typed – character now appears at a different spot within the frame, as many other characters do.

How should the app know that (or when) you want your – character be treated as hyphen?
When you type it manually it is just a letter like all other characters, none of them disappears with a change of the line break position (= frame width).

In that way there happened no automatic re-formatting and no destruction done by the app but instead you cause what you feel as destruction by not using auto-hyphenation. To repair your text you either can continue to do it your manually way – or you can use the help of the app and activate its automatic hyphenation feature, which was invented to prevent cases like yours.

Or, a third option, you replace your manually typed – symbols with the useful hyphenation glyph called "soft hyphen" which will work for you as a hyphenation even without activated auto-hyphenation. You find this helpful glyph in menu "Text" > "Insert" > "Dashes and Hyphens" > "Soft Hyphen". You alternatively can paste it with its shortcut command. To replace all your – with 1 click you can use the Find and Replace Panel.

1811748764_textftramesize-softhyphen.jpg.6e73cde5b2e8cf3e3f7d2a7da525e943.jpg


macOS 10.12.6,  Macbook Pro 15" + Eizo 24"

Share this post


Link to post
Share on other sites

When I place the image via the image frame, the result looks much better and there is no reformatting, at least on the left side of the image.340841135_Bildschirmfoto2019-09-25um18_40_10.png.fcd7e4df75eb2dcf27a972811adab36f.png

Share this post


Link to post
Share on other sites

You compare very different situations. To get your assumption proved that the type of frame influences the text flow you need to compare same text and same frame dimensions.

However, in both your screenshots I can not recognize any "reformatting" as a result of text wrap. The Text Wrap feature only influences column width, nothing else. Any further change is a consequency and a matter of your chosen formatting, respectively dimensions of frames and font size.

The "gaps" you see in your text are the result of column width, font size, number of words per line and your formatting as justified text block. It is obvious that a line with few but long words as in "vergangenen Monaten bundesweite" can result in larger white spaces than a line with shorter + more words.

As long you define to type hyphenation manually yourself and as – characters the software has no chance to do the text flow properly, neither hyphenation nor line breaks or optimized spacing. You prevent to get the job done, so don't wonder about the consequences of your deliberately restricting the software. Feel free to use software hyphenation instead.
 


macOS 10.12.6,  Macbook Pro 15" + Eizo 24"

Share this post


Link to post
Share on other sites
On 10/1/2019 at 2:30 PM, dtpunger said:

In version 1.7.3 this issue seems being solved. Now the text stays put as I set it.

Regardless, consider switching to using soft hyphens as @thomaso suggested.  Text does tend to reflow at times, particularly when documents are changed, and soft hyphens can help to ease the situation when you are dealing with those changes down the road, potentially saving you a lot of clean-up effort.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.