Jump to content
Ricardo Zea

Affinity Designer doesn't want to start - Win10

Recommended Posts

After I updated to the latest version of Affinity Designer (version 1.7.2), it no longer starts. Like, I click the icon on the Task Bar and it never opens.

Any idea why is this happening?

Thanks,

Share this post


Link to post
Share on other sites

Thanks but that didn't work.

I also noticed in the Task Manager that the AD executable starts to run and then it shuts down.

AD used to work just fine before installing 1.7.2. - I reinstalled version 1.6.5.123 and now I get the message attached:

Screenshot - 9_18_2019 , 9_35_36 PM.png

Any idea what may be causing this then?

Share this post


Link to post
Share on other sites
On 9/19/2019 at 3:38 AM, Ricardo Zea said:

Thanks but that didn't work.

I also noticed in the Task Manager that the AD executable starts to run and then it shuts down.

AD used to work just fine before installing 1.7.2. - I reinstalled version 1.6.5.123 and now I get the message attached:

Screenshot - 9_18_2019 , 9_35_36 PM.png

Any idea what may be causing this then?

They call it support I have another name for it.
I to have problems Starting the program after an update and this fear to upgrade is with Photo and designer.
 have a look at the things I tried... 

Sometimes installing a beta will let you run the beta, but not the stable version British Humor?

Best regards
Guy Forssman 

Share this post


Link to post
Share on other sites
12 minutes ago, Forssux said:

They call it support I have another name for it.

Well they have tried to help you,now didn't they?
It must be your system as many other win10 users have no issues running the programs.
Or do you want them to drop by to fix it?

Share this post


Link to post
Share on other sites
2 minutes ago, haakoo said:

Well they have tried to help you,now didn't they?
It must be your system as many other win10 users have no issues running the programs.
Or do you want them to drop by to fix it?

It's nice you're a believer but honestly ...wat a strange remark..
 

Share this post


Link to post
Share on other sites

Didn't people from Serif try to help you?
I see at least two trying to,so why do you call that not support?
I run win 10 with the windows update KB4515384 / 3.5 and 48 .NET installed and don't have any problems with updating or running release or beta versions.

 

Share this post


Link to post
Share on other sites

@Forssux Thanks for the link, hopefully one of the things they suggest to you actually works for me. However, my issue isn't having the software to install, it actually installs just fine. My issue is that Designer shuts down as soon as it starts running. Doesn't look like this is something happening to you, is it?

@haakoo It's great that you're a dedicated user and all, but I don't see you helping either Forssux or me here, just scolding at him/her, who is clearly frustrated. I am as well.

And yeah, you know what, if we are paying customers Serif should drop by and help if that was ever a possibility.

On that note, rather than trolling, do you have any valuable pointers on how to fix this issue anyhow?

Share this post


Link to post
Share on other sites

Do you have any of the third-party software installed that is known to cause issues with the Affinity suite?

A number of people recently have been reporting issues using RivaTuner, for example, but anything on that list can cause odd failures.


-- Walt

Windows 10 Home, version 2004 (19041.388),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.8.5.703 and 1.9.0.852 Beta   / Affinity Designer 1.8.5.703 and 1.9.0.852 Beta  / Affinity Publisher 1.8.5.703 and 1.9.0.850 Beta.

Share this post


Link to post
Share on other sites

Also, are you getting crash reports that you could upload?

Also, if you can look at the Windows Event Viewer, you might find something interesting, as the user in this post did:

 


-- Walt

Windows 10 Home, version 2004 (19041.388),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.8.5.703 and 1.9.0.852 Beta   / Affinity Designer 1.8.5.703 and 1.9.0.852 Beta  / Affinity Publisher 1.8.5.703 and 1.9.0.850 Beta.

Share this post


Link to post
Share on other sites
9 hours ago, walt.farrell said:

Do you have any of the third-party software installed that is known to cause issues with the Affinity suite?

A number of people recently have been reporting issues using RivaTuner, for example, but anything on that list can cause odd failures.

HUGE Thanks for providing the links @walt.farrell, very helpful. And in fact, I do have RivaTuner installed since I run MSI Afterburner to monitor my video card.

However, I was able to fix the issue (maybe temporarily) by uninstalling the Windows Update KB451538 rather than dealing with RivaTuner.

Here's are the steps to uninstall a Windows Update:

  1. Press Win+I to open Windows Settings.

  2. Choose Update & Security.

  3. Click the View update history link.

  4. Click the Uninstall updates link at the top left.

  5. Look for Windows Update KB451538 and uninstall it.

  6. Restart Windows.

That did it for me.

I found that fix in the forum that @Forssux shared in which he's having similar issues but with Affinity Photo. Here's the link to that forum again:

Thanks go to @Lee D as well for helping us out albeit only comment in this forum >_<

Thank you for your help.

 

Share this post


Link to post
Share on other sites

You're welcome.


-- Walt

Windows 10 Home, version 2004 (19041.388),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.8.5.703 and 1.9.0.852 Beta   / Affinity Designer 1.8.5.703 and 1.9.0.852 Beta  / Affinity Publisher 1.8.5.703 and 1.9.0.850 Beta.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.