Jump to content
DenisNZ

Affinity Photo loses most keyboard shortcuts on round trip with Capture One Pro

Recommended Posts

I've recently started using round trip editing from Capture One Pro (12) to Affinity Photo and have found that AP loses most of the keyboard shortcuts after the first photo. Workflow - edit photo in C1 then Edit With AP - C1 creates PDF and passes it off to AP - AP is not open at this point - AP opens and all keyboard shortcuts work. Save PDF and close file but not AP.

Edit another photo in C1, pass it off to AP and most keyboard shortcuts no longer work. The spacebar for switching to the hand tool to move around a zoomed-in photo works but none of the others.

Windows 10 fully updated. C1 fully updated. AP fully updated.

I have this problem on 2 different computers.

Share this post


Link to post
Share on other sites

I found that the same problem occurs when going from Lightroom to Affinity Photo round trip.

Further trial and error I found that the problem only happens when using Alt+Tab to switch from AP to Capture One (or Lightroom). If I switch back using the Taskbar then there is no problem.

Share this post


Link to post
Share on other sites

Hello DenisNZ,

Two of us have tried this on different machines using the Lightroom to Affinity Photo method but we cannot reproduce this.

I wonder if you are experiencing some aftermath of the issue we had with the upgrade to 1.7 regarding shortcuts. On one of the machines you can reproduce this one, could you go to %AppData%\Affinity\Photo\ and rename the 1.0 folder to 1.1 and then launch Affinity. This will perform a safe reset on the app (as we've just backed up your user data) and may resolve the issue for you.

Share this post


Link to post
Share on other sites

Hi Chris B,

Made no difference. Just one of those weird glitches I guess. If I use the taskbar to switch between apps than all is good. So as long as I avoid Alt+Tab to switch back then I'm fine.

Share this post


Link to post
Share on other sites

Bizarre that it works fine for us. If you have time to write back with your exact mouse clicks and shortcut actions I'd be happy to have another look. I just cannot work out why Affinity would lose its shortcuts (especially if they are still present in the Preferences > Keyboard Shortcuts menu).

Share this post


Link to post
Share on other sites

Hi Chris,

I've done a bit more testing and it is nothing to do with round-tripping between Lightroom and Affinity Photo.

It is all to do with switching between windows with Alt+Tab keyboard shortcut.

If I have Photo open and Designer open, both are working with keyboard shortcuts - but if I switch between them several times using Alt+Tab then both Photo and Designer lose their keyboard shortcuts.

Seems that the Affinity programs don't like the way Windows switches between windows using that keyboard shortcut. If you switch between them using mouse click on the taskbar icons, or directly on the windows themselves (when not full screen) then keyboard shortcuts are unaffected.

 

Share this post


Link to post
Share on other sites

Follow up to my previous post - seems you don't need to swap windows at all.

Have only Affinity Photo open, with a photo to zoom into, and no other windows running.

Alt+Tab appears to do nothing because there are no other windows to switch to - but it kills most of the keyboard shortcuts in AP.

Share this post


Link to post
Share on other sites

Hi,

I could reproduce. I think that the problem can be narrowed down to the Alt key handling in AP. Normally, when hitting the Alt key, the application's main menu switches to a special mode where it expects a character key to be hit. If this character corresponds to an underlined letter in the currently active menu, the corresponding command is executed. In any application, using alt-tab enables this special state in the application that currently has the focus but then, Windows tries to show the other running apps, allowing the user to select one to switch to. If the user returns to the application that had the focus when alt-tab was hit, the special "Alt" mode is then disabled. This doesn't seem to be the case in AP. So, the program is still expecting a character key to be hit and all keyboard shortcuts are disabled. Hitting the Alt key releases the special mode and things then works as usual.

My two cents...


--Patrick
Hamburg ist der wahre Grund
warum Kompassnadeln nach Norden zeigen.

Share this post


Link to post
Share on other sites
On 9/23/2019 at 9:39 AM, Samoreen said:

Hi,

I could reproduce. I think that the problem can be narrowed down to the Alt key handling in AP. Normally, when hitting the Alt key, the application's main menu switches to a special mode where it expects a character key to be hit. If this character corresponds to an underlined letter in the currently active menu, the corresponding command is executed. In any application, using alt-tab enables this special state in the application that currently has the focus but then, Windows tries to show the other running apps, allowing the user to select one to switch to. If the user returns to the application that had the focus when alt-tab was hit, the special "Alt" mode is then disabled. This doesn't seem to be the case in AP. So, the program is still expecting a character key to be hit and all keyboard shortcuts are disabled. Hitting the Alt key releases the special mode and things then works as usual.

My two cents...

I think you are absolutely spot on—thank you.

@DenisNZ and thanks for persevering. I can get this logged now.

Share this post


Link to post
Share on other sites

Hi!

Thanks Samoreen for the tips.

Same here, Affinity Photo looses some functionalities after Alt-Tab to any other program.

 Move Tool (V) or Color Picker, even if chosen with the mouse in the UI does not respond anymore, and I have to restart Affinity Photo.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.