Jump to content
CFeleki

New update 1.7.2 very slow and freezing

Recommended Posts

I just downloaded the new update for Affinity Photo and it is extremely slow with what I would consider basic functions (ie. curves, exporting etc). The program constantly freezes when trying to use the gradient tool, and any filters (ie haze removal), unable to access tone mapping persona without having to force quite the program. I can barely edit a photo. 

 

Share this post


Link to post
Share on other sites

Hi CFeleki,
Welcome to Affinity Forums :)
Please try the following: press and hold ctrl while launching the application until a Clear User Data dialog appears. Keep the first three checkboxes ticked only and press Clear. Try the program again. Are you able to access tone mapping and is all the rest working as it should or it's still slow? If that's the case go to Affinity Photo Preferences, Performance section and disable/untick Enable Metal compute acceleration. Check if the app is still lagging/slow.

Do you mind attaching your Mac specs please (menu Apple > About this Mac). Keep the Serial Number hidden/out of the capture. Thanks.

Share this post


Link to post
Share on other sites

Thanks MEB for the quick reply. 

I have done as you asked, including enabling Metal Compute Acceleration. Yesterday I also re-installed the program... as of this morning it seems to be running better, but I have not had a chance to sit down and work yet. I have been able to to enter tone mapping, the program did not freeze when trying to do some of the same actions as I had before, however I have only one photo open at the moment. 

I will update you later today if things seem to be slowing down again. 

My Mac specs are 1748824945_ScreenShot2019-09-13at8_32_06AM.png.1577c3c64290381c57cc1c19a6182bc6.png

Thanks again. 

C

 

Share this post


Link to post
Share on other sites

Hi again, 

Things seem to be getting worse, trying to use the paint brush to apply a mask will sometimes crash the computer, When I try to flatten a document I am getting the checkerboard background for no image... I have actually upgraded my computer to a solid state drive and upped the RAM, and the program seem worse then ever.

 

Share this post


Link to post
Share on other sites

Hi CFeleki,
Currently do you have Metal Compute Acceleration enabled (ticked) or disabled in Affinity Photo Preferences, Performance section? Do you mind attaching the document that when flattened becomes empty/no image please? I can provide an upload link if you wish to keep the file private - just let me know.

Share this post


Link to post
Share on other sites

I do have Metal Compute ticked. Here is the file, it is not flattened at the moment. This morning, when I tried to flatten there was no problem, however last night I tried 4 times and it always came out with the checker pattern.

It seems that the first file I work on will go somewhat smoothly for a bit, and then things will start to glitch, slow down, or freeze. If I close everything sometimes it will be back to ok, or it will still not run smoothly... Yesterday the program restarted my computer unexpectedly twice.

The major slow downs seemed to start when I tried to create layer masks in an adjustment layer. I used the paint brush tool to modify the adjustment layer and often there would be a significant lag, or the computer would shut down. 

Previously this would happen with the dodge and burn tools as well.

Side note, I have also noticed that the denoise options do not work...

kristen.tiff

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.