Jump to content
andy5812

Keep text formatting on copy/paste from Word/Google Docs

Recommended Posts

Hi

I've googled and googled this but not found an answer.  Ctrl-Alt-Shift-V, Ctrl-Shift-V, Ctrl-V all give me the same outcome - my text from Word and Google Docs files loses all its formatting - bold, italics, etc - when I bring it into Publisher.  I'm fine with changing the font size, spacing etc, but in total I am putting close to 300,000 words across, and going through all of that word by word seems crazy.  I am 99% certain this is a case of user error, so if someone could point me onto the right track I'd be super-grateful.

Cheers

Andy

Share this post


Link to post
Share on other sites

Hi andy5812 and Welcome to the Forums,

I can't replicate this copy and pasting from Word but i can from Google Docs, are you on Mac or Windows? 

One thing that may help, you can save the work from Google Docs or Word as a docx and then import this into Publisher using File>Place and that should keep the formatting :) 

Share this post


Link to post
Share on other sites

Hey Stokerg, thanks for the swift reply.  I'm on Windows.  I've tried what you suggested but all the bold and italics are still getting stripped out so I'm left with just plain text :-(  I tried doing copy/paste from word, as well as File Place (both inside an existing text box and onto a blank page, but still the same result.  Any ideas what I'm doing wrong/not doing right?

Share this post


Link to post
Share on other sites

Fantastic - thank you.  I've uploaded the one I've been trying (there are 55 more, and that's just in the transcripts, so if you find a solution I owe you big time!).  I've also uploaded teh Publisher file, in case I've done something funky in that, and that's causing the problem.

Share this post


Link to post
Share on other sites

Hi Andy,

I was i started a new document and used File>Place and placed your file and the formatting was retained.  The heading on page one was in bold and underlined and italics are also present and correct.  You can download my version here

I'm still looking into why it wasn't placing correctly for you.  But you may want to quickly try installing the beta from here It installs as a separate app and if you just start a New Document in the beta and then use File>Place and see what results you get.   

Share this post


Link to post
Share on other sites

Thanks for looking at this, Stokerg.  I have no idea what I am doing wrong, but I am still losing the formatting.  I downloaded the beta, fired up a new document - A4 for Print and followed what you did - File > Place, but still the  formatting gets stripped :-(

Share this post


Link to post
Share on other sites

Hi Andy,

Do you have the fonts used in the document installed on your Pc?  Bit of a long shot, but thought i'd check.

Share this post


Link to post
Share on other sites

Seems like the long-shots are the best.  I feel like a total idiot!  Font was displaying fine (Open Sans), but when I went into Fontbase it wasn't showing as activated.  Activated it and bingo, all formatting works - either through a File > Place or through a simple copy-paste, in both the beta and stable versions.

Sorry to have taken up your time with such a rookie error, but thank you so much for solving this for me.

Share this post


Link to post
Share on other sites

Hi Andy,

Great news :) 

Not a waste of time at all, hopefully others who encounter the same issue will find this thread and see the solution :) 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.