Jump to content
ahnungsloser

Affinity Publisher: Numeration

Recommended Posts

Actually I try to rebuild a Document from InDesign in Affinity Publisher. But I got some problems to make automatic numbering in Affinity Publisher to work.

wrong Numeration
The higher Number should be on the right page, not on the left one. No Idea how I could that get to work the right way -> bug?

Subtitles
I could insert subtitles, but I have no idea how to get the main-number (level 1) to get in front. In InDesign it's possible to define the numeration and I tried to insert the same name in "Name:". But I didn't find any way to bring that to work!

Thanks for support with this great piece of software!

Layout.pngPreferences_2.png

Preferences_1.png

Edited by ahnungsloser

Share this post


Link to post
Share on other sites
4 hours ago, ahnungsloser said:

wrong Numeration
The higher Number should be on the right page, not on the left one. No Idea how I could that get to work the right way -> bug?

It would help to have a sample .afpub document, not just a screenshot.

But I will make a guess: It's acting as though you have your the Text Frame on the right-hand page flowing to the Text Frame on the left-hand page. (That is, the link runs from the lower-right of the right-hand frame to the upper-left of the left-hand frame. It should be the other way.)

Looking at it with View > Show Text Flow enabled and one of the Text Frames selected would show that, and would be a useful screenshot to have.

Subtitles: Sorry, I don't understand what you're trying to do for your second question.


-- Walt

Windows 10 Home, version 1903 (18362.239), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.2.471 and 1.7.2.464 Beta   / Affinity Designer 1.7.2.471 and 1.7.2.4464 Beta  / Affinity Publisher 1.7.2.471 and 1.7.3.475 Beta

Share this post


Link to post
Share on other sites
7 hours ago, ahnungsloser said:

wrong Numeration
The higher Number should be on the right page, not on the left one. No Idea how I could that get to work the right way -> bug?

It uses z-order to decide the ordering of unconnected frames. It doesn't use x/y position because if you had a 2x2 arrangement, you might want it to left-to-right then top-to-bottom, or top-to-bottom then left-to-right. If you go to the master page and use the Layers panel to swap the text frames around, it should work as you want.

 

7 hours ago, ahnungsloser said:

Subtitles

I could insert subtitles, but I have no idea how to get the main-number (level 1) to get in front. In InDesign it's possible to define the numeration and I tried to insert the same name in "Name:". But I didn't find any way to bring that to work!

I'm not sure I understand you, but I notice you have Global ticked only for the level 1 list. It should also be ticked for the level 2 list. That's why you are getting 0.1 instead of 2.1.

Share this post


Link to post
Share on other sites

@Dave Harris

Thanks for your support, that sounds logical.

I tried all of your tipps and that solved the subtitles but not the rest. Now I still got this behavior: The main title is on the top of the Layers, but the subtitles are still with the wrong first number (as they're above the main titles) -> for example: 1.2 but it should be 2.2.

If you go to page 4 and 5 in the document above, the numbers are still wrong (on the left side should be 4 and on the right 5). There I can't change anything by Layers and if I add a page I can't arrange that in a different way.

Share this post


Link to post
Share on other sites
16 hours ago, ahnungsloser said:

I tried all of your tipps and that solved the subtitles but not the rest. Now I still got this behavior: The main title is on the top of the Layers, but the subtitles are still with the wrong first number (as they're above the main titles) -> for example: 1.2 but it should be 2.2.

Ah, this is in a Table of Contents. It looks like paragraph numbering doesn't interact well with ToC. The ToC will effectively freeze fields when it copies them, but it doesn't freeze numbered lists the same way. This is a bug. I'll log it to be fixed.

It looks like the ToC text styles apply their own numbering, and used different settings. If you use the same settings but make the ToC list non-global, it should work reasonably well. Also, after you edit the main text you will need to update the ToC.

16 hours ago, ahnungsloser said:

If you go to page 4 and 5 in the document above, the numbers are still wrong (on the left side should be 4 and on the right 5). There I can't change anything by Layers and if I add a page I can't arrange that in a different way.

On this spread it is the master pages that have the wrong z-order. They can be reordered, although it's not as easy as it should be. If you go to the Layers panel, unexpand the second master page, you should then be able to drag the first master page to below it. I'll log this to be improved too.

I've attached Testfile2.afpub that shows what I think you want.

Testfile2.afpub

Share this post


Link to post
Share on other sites

Thanks.

8 hours ago, Dave Harris said:

Ah, this is in a Table of Contents. It looks like paragraph numbering doesn't interact well with ToC. The ToC will effectively freeze fields when it copies them, but it doesn't freeze numbered lists the same way. This is a bug. I'll log it to be fixed.

It looks like the ToC text styles apply their own numbering, and used different settings. If you use the same settings but make the ToC list non-global, it should work reasonably well. Also, after you edit the main text you will need to update the ToC.

Actually there's no way to get the number 1.1 and in the next one 2.1 -> but great if it gets fixed.

8 hours ago, Dave Harris said:

On this spread it is the master pages that have the wrong z-order. They can be reordered, although it's not as easy as it should be. If you go to the Layers panel, unexpand the second master page, you should then be able to drag the first master page to below it. I'll log this to be improved too.

I've attached Testfile2.afpub that shows what I think you want.

Testfile2.afpub

I couldn't do that, but in your attached File it's correct. But no worries, if it gets improved I can wait.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×