Jump to content
Guest-354025

How to MOVE without "Transforming"

Recommended Posts

I tried to use the Move tool to move something. To Move in, say, Text, one looks for the black cross-hairs symbol.

But Move alone, when used with a Paste(d) object, only allowed me to Transform the Pasted Object. All I wanted to do is Move it.

The Help section on Move is one of the most recondite I have encountered on any Serif Help page. 

If someone can tell me how to simply Move a Paste(d) object, I would deeply appreciate it.

Thank you.

Share this post


Link to post
Share on other sites

Which Affinity software are you using? ..and what is it you are pasting in? In theory you should simply click and drag on the object (not the handles) to move it? That seems consistent across all packages.

Share this post


Link to post
Share on other sites

Hi American,
Can you post a screenshot of the app's interface with the layers panel visible and the object you are trying to move selected (with the Move Tool) so we can see what you are trying to do? Thanks.

Share this post


Link to post
Share on other sites
18 minutes ago, American said:

The Move Tool in, say, Text, is identified by the black cross-hairs symbol.

Either Move Tool – or Text tool?

For instance AfPublisher: The Move Tool switches to Text tool with a double click on a text frame. Then various cursors can appear, depending on the situation. One is looking like your seen cross-hairs symbol and it appears if you move the mouse outside the frame. Another text tool cursor appears if you move the cursor exactly over the frames edge: then it looks like a double arrow and, only then, you can move the frame (or another) even with the text tool.

1526909824_movewithtexttool.jpg.e9d600602d1f78d2157a954e98ca5a2c.jpg

Share this post


Link to post
Share on other sites
8 hours ago, MEB said:

Hi American,
Can you post a screenshot of the app's interface with the layers panel visible and the object you are trying to move selected (with the Move Tool) so we can see what you are trying to do? Thanks.

I really cannot but will recreate the basics.  @Dazzler  suggested I try to Click and Drag. I should have said that that was the first thing I attempted before looking for the Crosshairs.

Share this post


Link to post
Share on other sites
8 hours ago, thomaso said:

Either Move Tool – or Text tool?

 

Move. I had hoped I made clear that I was using Text as an example of something I could move. Thanks for the reply!

Share this post


Link to post
Share on other sites

Hi American,
A screenshot or a small clip/video would help to clarify what you are trying to achieve so we can advise you better. From your description alone it's not clear what you are trying to do/what's happening.

Share this post


Link to post
Share on other sites
8 hours ago, MEB said:

Hi American,
Can you post a screenshot of the app's interface with the layers panel visible and the object you are trying to move selected (with the Move Tool) so we can see what you are trying to do? Thanks.

@MEB  A very strange thing happened while I was in the process of deleting Layers I could/would not take screenshots of to upload. When I had all the Text Layers hidden (unchecked boxes), I tried clicking-and-dragging--and it worked. I then replaced all the text I had to remove in order to safeguard privacy, and the objects again would not move. I will recreate the conditions again for myself and see if the same thing happens in an entirely new project. The Affinity version I'm using is the latest download, 1.7.2.

 

Share this post


Link to post
Share on other sites
8 minutes ago, American said:

Move. I had hoped I made clear that I was using Text as an example of something I could move

No, it wasn't clear because you mentioned the cross-hairs cursor which is not typical for the Move Tool.

Did you have set your app preference to always cross-hair cursor? If not, then with Move Tool you should see a black arrow. Regardless which cursor preference you have selected you can move by simply click-drag with move tool. In AfPublisher for instance.

If it does not work for you: what happens if you do so?

2 minutes ago, American said:

the objects again would not move.

What happens instead?

And, as asked before, in what Affinity app?

Share this post


Link to post
Share on other sites
8 hours ago, thomaso said:

No, it wasn't clear because you mentioned the cross-hairs cursor which is not typical for the Move Tool.

Did you have set your app preference to always cross-hair cursor? If not, then with Move Tool you should see a black arrow. Regardless which cursor preference you have selected you can move by simply click-drag with move tool. In AfPublisher for instance.

If it does not work for you: what happens if you do so?
And, as asked before, in what Affinity app?

Thank you. As I said to MEB, 1.7.2, the latest download.

Share this post


Link to post
Share on other sites

One thing I can think of that may be stopping you moving something is a locked layer (unlikely if you've just pasted something). Check in the layers panel that there isn't a padlock showing on the layer you are trying to move. If there is, then uncheck the padlock symbol at the top of the layers panel.  That would also stop you transforming things so, so I'm still a bit confused as to what is happening for you, and what crosshair you are seeing, as with the move tool I don't an arrow unless I hover over the  handles or edges.

 

Share this post


Link to post
Share on other sites
2 minutes ago, American said:

1.7.2, the latest download. 

I guess after 220 posts you are aware that Affinity has 3 different apps with 3 different names. What is the name of yours (and don't answer you did not give it a name yet!)

Share this post


Link to post
Share on other sites
8 hours ago, Dazzler said:

One thing I can think of that may be stopping you moving something is a locked layer (unlikely if you've just pasted something). Check in the layers panel that there isn't a padlock showing on the layer you are trying to move. If there is, then uncheck the padlock symbol at the top of the layers panel.  That would also stop you transforming things so, so I'm still a bit confused as to what is happening for you, and what crosshair you are seeing, as with the move tool I don't an arrow unless I hover over the  handles or edges.

 

The Layer was not locked. It installed itself however beneath the Pixel (Background) Layer. I did not install it there manually. As I said to @MEB, I will try to recreate the conditions and see if the Paste having lodged itself beneath the Pixel (Background) layer was what prevented click-and-drag AND cross-hairs moving. (Interestingly, I was able to Transform the object, but I did not want to transform it.)

Thank you.

Share this post


Link to post
Share on other sites
12 minutes ago, American said:

@MEB  A very strange thing happened while I was in the process of deleting Layers I could/would not take screenshots of to upload. When I had all the Text Layers hidden (unchecked boxes), I tried clicking-and-dragging--and it worked. I then replaced all the text I had to remove in order to safeguard privacy, and the objects again would not move. I will recreate the conditions again for myself and see if the same thing happens in an entirely new project. The Affinity version I'm using is the latest download, 1.7.2.

 

If you wish to keep the file private, I can provide an upload link for you so you can send the original file directly to us without making any changes. The file will be deleted after being inspected. Just let me know and I will prepare the link for you.

Share this post


Link to post
Share on other sites
8 hours ago, thomaso said:

I guess after 220 posts you are aware that Affinity has 3 different apps with 3 different names. What is the name of yours (and don't answer you did not give it a name yet!)

Sir (or Madam), Your assiduousness is quite touching. I have posted in the Windows Forum since the Forums opened in 2016 or early 2017 assuming that the Forum was for Affinity Photo. My gratitude cannot be expressed in words for your help.

Share this post


Link to post
Share on other sites

@MEB Thanks, MEB! I will do this later in the day. As of now, the problem has been solved. And as I said to @Dazzler there is a possibility the problem appeared because the Paste lodged itself beneath the Pixel (Background) Layer. Not paying attention to the Layers Panel while I was (and still am) working on a pretty time-sensitive project, I expected the Layer to "go to the top," as Layers in Affinity Photo generally do. 

Again, thanks.

Share this post


Link to post
Share on other sites
1 hour ago, American said:

assuming that the Forum was for Affinity Photo

This particular section - "Affinity on Desktop Questions (Mac and Windows)" - covers all three apps on both platforms and thus it is not clear from the question alone which one you were referring to.  Thanks for clarifying that.

 

1 hour ago, American said:

I expected the Layer to "go to the top," as Layers in Affinity Photo generally do.

Wondering if you might have enabled the "Insert behind the selection" button on the toolbar?  There are three buttons there that change where newly added layers are placed.

Share this post


Link to post
Share on other sites
On 9/9/2019 at 8:52 AM, fde101 said:

Wondering if you might have enabled the "Insert behind the selection" button on the toolbar?  There are three buttons there that change where newly added layers are placed.

I had no idea this feature/these features existed. Thank you!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.