Jump to content
TracyD

Inconsistent behavior - bezier curves, rotation, and dragging to move

Recommended Posts

I'm trialling Designer as a replacement for Illustrator. I'm having trouble with some inconsistent behavior - it works normally for a while, then the behavior of some functions changes. I am not sure if I'm accidentally changing settings somehow, or if the program is partially crashing / needs more ram, or something else is going on.

Functions that seem to be lost after maybe twenty minutes of working:

  • When creating a path with the pen tool, click and drag doesn't create bezier curves when creating a new node
  • Selected items will not rotate
  • Selected items cannot be dragged to move them, only nudged

Restarting the program restores original functionality.

I'm still learning the shortcuts so I don't know if it's possible I'm accidentally changing a setting by keying in an incorrect shortcut, but I suspect the issue is either due to insufficient memory or a bug.

I'm running Windows 10 with 4gb of ram, using a wacom tablet. The tablet is an old Intuos 3 but has been working normally. The laptop is admittedly slow despite being only a year old - I'm trying to figure out if it is capable of running design software or if I need to replace my desktop that just died.

Share this post


Link to post
Share on other sites

Hi TracyD and Welcome to the Forums,

How does it perform without the tablet attached? I have seen some slow downs which seem to related to a tablet (but i think they also involved screen recording at the same time).  Be interesting to see if the same happens if you use the mouse/trackpad :) without the tablet connected.

Also can you attach a sample file or upload one here , as that may help in trying to replicate the problem :) 

Share this post


Link to post
Share on other sites

Thanks for the suggestion to unplug the tablet - I gave it a try today but the issue did not resolve when I unplugged the tablet. I then tried using the trackpad to move the object I'd been trying to move, which also did not work. I tried plugging the tablet back in, which still didn't work, and unplugged it again. The program froze up completely after that (grayed out / nonresponsive) and the computer crashed and rebooted.

I suspect this is a memory problem with my computer because Firefox has also been running slowly, but just in case I've attached the file that's been crashing.

WASP cleanup.afdesign

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×