Jump to content
tariq

1.7 introduced "tab" to hide UI bug

Recommended Posts

In previous versions I could use TAB to toggle away the panels and tools - which was useful in full-screen demonstrations or screen recordings .. I could show the full image without tools / UI in the way

 

Now in 1.7 the first TAB takes everything away - great.

 

But TAB again doesn't bring them back and I have to re-enable 3 vows:

 * view - studio - unhide studio

 * show tools

* show context toolbar

and maybe another one

 

when not in full screen mode this toggling is ok , the bug happens when clicking that macOS "green button" window decorator to go full screen ... 

Share this post


Link to post
Share on other sites

Hey tariq,

TAB should only temporarily hide the UI elements—not disable them. It sounds like when you enter full-screen, those settings are being disabled and do not come back with TAB?

I've tried and failed to reproduce this. Would you mind doing a screen recording so I can see exactly what is going wrong?

Thanks :) 

Share this post


Link to post
Share on other sites

thanks @Chris B

 

I've found the steps to reproduce it

  1. open photo, with tools/bars/tabs
  2. normal TAB toggles then on/off
  3. edit a doc - eg brush on canvas
  4. quit (cmd-Q) when in full screen mode
  5. open Photos again and this time there are no toolbars and tab toggle fails

 

video attached - TAB is first shown to work, then failing at 30-36 seconds..

 

Share this post


Link to post
Share on other sites

@Chris B slight aside but you'll notice the performance is terrible (latency and poor sample rate when painting) - any suggestions on what might be causing it .. ? it doesn't happen on my MacBook Air but does on my 15" MacBook Pro 2015 

Share this post


Link to post
Share on other sites
15 hours ago, tariq said:

@Chris B slight aside but you'll notice the performance is terrible (latency and poor sample rate when painting) - any suggestions on what might be causing it .. ? it doesn't happen on my MacBook Air but does on my 15" MacBook Pro 2015 

I wondered about that and thought it was a video issue! Can you check to see if you have Metal compute enabled in Preferences > Performance and either enable or disable it or try using OpenGL.

Share this post


Link to post
Share on other sites
On 9/18/2019 at 1:43 PM, Chris B said:

I wondered about that and thought it was a video issue! Can you check to see if you have Metal compute enabled in Preferences > Performance and either enable or disable it or try using OpenGL.

tried those options in several combinations and sadly didn't fix it

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.