Jump to content
RyanH

Top of a new document in Separated mode is hidden under toolbar

Recommended Posts

Forgive me if this is a known issue, but when I create a new document (by the way, THANK YOU so much for adding "New Document from clipboard" !!! to the beta) and I'm in Separated mode, the top of the window immediately gets hidden from view, not allowing me to grab/resize the window, and move it into place, etc. (example in screenshot).

 

One thing to note, is that if I drag an image (or designer file) onto the icon, Designer opens the file, and actually bumps it down perfectly under the toolbar how I would expect it to work when creating a new document.. so this only seems to be a new document issue.

 

Thanks, and keep up the great work!

post-12864-0-79892700-1435202976_thumb.png

Share this post


Link to post
Share on other sites

Hi RyanH,

 

Thanks for the screenshot.  Sadly I don't get the same.  The new Document is always started below the main toolbar (see attached screen recording).

 

Could you try doing a quick reset of Affinity Designer and let me know if that resolves it.  To carry out the reset do the following:

Exit Affinity Designer

Press and hold ⌃(ctrlwhile launching it and then choose Clear from the dialog that will open.

Note this will reset any customisations you may have made. 

 

As for the New Document from clipboard, I was just as happy, as you are when I noticed that had been introduced, saves A LOT of time :)

sep mode new doc.mov

Share this post


Link to post
Share on other sites

Hi stokerg,

 

Thank you for replying with an example!

 

I followed your advice, (cleared everything) and the window still starts under the tool bar... I thought since maybe you have your toolbar not docked up against the Finder bar that might help, so I moved it away, and then tried with a new document. No dice. Then I thought since I'm only on 1440x900 display, that may be the reason, (I also tried hiding my dock) but still the same.

 

The good news is that when I do open, or drag a file onto the icon, it does open it below the toolbar correctly, so I have hope that this issue can be worked out at some point!

 

I hate to be the complainer, (especially when there is so much greatness) but it's annoying to have to grab the toolbar, and move it before I start working on a new document each time :) Obviously 1440x900 is not a big resolution, I hope to get a retina macbook pro soon!

Share this post


Link to post
Share on other sites

Hi RyanH,

 

I'll do some more playing around with this and see if i can replicate the same issue you are having.  I suspect it could be down to the screen resolution, but will need to track down a smaller resolution Mac to see if i get the same.

 

I use a MacBook Pro with retina display at home and have to say it is a joy to work with.  Pains me if I need to do any photo editing on a PC now as im that used to the rich colours the retina display gives me :)  So its well worth the upgrade for the screen alone and i'm sure you will be happy when you take the leap and upgrade :)

Share this post


Link to post
Share on other sites

Hi RyanH, stokerg,

I've been able to replicate the issue using an 2008 Macbook (1280x800px).

In Separated Mode new documents are always placed on top left, similarly to what is shown in Ryan's screenshot, no matter if you moved them to other position in earlier sessions. So unless the main toolbar is anywhere else, we always have to move it our of the way to access document's titlebar / controls.

Issue logged to be looked at.

Share this post


Link to post
Share on other sites

Thanks MEB :)

 

I was planning on checking this on a friend's Macbook at the weekend, so you have saved me a job :)

Share this post


Link to post
Share on other sites

Hey MEB & stokerg,

 

@stokerg Yeah I know, I hope to get a retina soon! The guys I work with have them, and I drool when I look at the sharpness of their screens! Can't wait to get one! And thanks for the response again!

 

@MEB Thank you for doing that!

 

Weird that if you just plainly open a file, the toolbar height is respected by the document, but not if it's a newly created document..

Share this post


Link to post
Share on other sites

I always work in separated mode and I've seen this before, but I'm getting this quite often lately in Affinity Photo. This seems like a fairly simple bug to fix (coordinate bounds checking), but I see that this thread is almost two years old and the bug is still not addressed. Why?

Share this post


Link to post
Share on other sites

I understand that. This one is more of an annoying bug, but I guess it's a frustration in general that the Mac apps are at 1.5 now and still feel fairly rough around the edges. And I have to wonder if Serif is trying to expand too quickly to other platforms instead of focusing first on the quality of the products you already have and customers are paying for. Obviously engineers don't always fall into simple buckets like that, but if you are not able to find time or able to hire more people to fix longstanding bugs like this, then there is a resourcing problem which affects me as a customer...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×