Jump to content

Recommended Posts

On 9/18/2019 at 11:16 AM, Pauls said:

Think we'll need to have a look at the file to investigate. You can upload it securely here

 

Uploaded to dropbox. It's happening on all of my files, so I uploaded 2 different afpub files with the generated PDFs. You can look at the PDF files to see that both TOC (H1s specifically) are messed up.

Share this post


Link to post
Share on other sites

Hi @JimWelch,

I'm still looking at this file a bit, but the text styles being used by the ToC are where this issue is originating from.

I'm trying to narrow down/fix what is in these styles that is causing the issue (they are inheriting some hyperlink styles which I believe is the cause, from what I can see) did this file originate from a much earlier version by chance?

Either way, if you create a new ToC text style and set it all up for Heading 1 and 2 it all works fine. Granted you will have to set this style up to be like the previous one (font/colour etc) but it's a workaround/fix for now.


Serif Europe Ltd. - www.serif.com

Share this post


Link to post
Share on other sites
12 minutes ago, Jon P said:

Hi @JimWelch,

I'm still looking at this file a bit, but the text styles being used by the ToC are where this issue is originating from.

I'm trying to narrow down/fix what is in these styles that is causing the issue (they are inheriting some hyperlink styles which I believe is the cause, from what I can see) did this file originate from a much earlier version by chance?

Either way, if you create a new ToC text style and set it all up for Heading 1 and 2 it all works fine. Granted you will have to set this style up to be like the previous one (font/colour etc) but it's a workaround/fix for now.

 

I used a template provided by another person.

 

Do you mean earlier version of AfPub? or earlier version of a doc?

 

Thanks

 

Share this post


Link to post
Share on other sites

Yeah as in like an early beta version before we released, I'm struggling to replicate what has happened to the text style here which is causing the issue.


Serif Europe Ltd. - www.serif.com

Share this post


Link to post
Share on other sites
5 minutes ago, Jon P said:

Yeah as in like an early beta version before we released, I'm struggling to replicate what has happened to the text style here which is causing the issue.

 

Is creating a new style, changing everything, then deleting the old style the only fix? Is there something I can unclick or change within the existing style?

Share this post


Link to post
Share on other sites

Basically I think this has happened because of an old bug which is now fixed, but if this document was created when that bug was still in the software the text style used has been effected by it, so the cleanest fix is probably to just re-create the style.

I will however speak to the developer tomorrow to clarify what I think has happened and let you know if there is a nicer way to fix this text style.


Serif Europe Ltd. - www.serif.com

Share this post


Link to post
Share on other sites
56 minutes ago, Jon P said:

@JimWelch Leave this with me for a day or so and I should be able to send you a fixed version of the file.

 

If possible, I'd rather have instructions than you fixing it. I know at least 1 of those 2 documents have changed since I uploaded them. And lots of other folks are using the same template, so if I had the steps I could forward them to the layout designer and they could forward them to others who might have the same problem but just never noticed that their TOC is borked.

 

thanks,

Jim

Share this post


Link to post
Share on other sites

I would advise against other people using the same base template because the ToC text styles have a hyperlink style associated with them due to a bug that was fixed in a later version of 1.7.0.

I can't really give you steps to fix it and retain those styles, as a developer has to run some code against the file to clear the associated hyperlink styles out, it isn't possible to do this from the app without deleting and re-creating the text styles which I've already advised. 

We could fix the template that is being provided if you want to send us that? May I ask where this template came from?

Thanks


Serif Europe Ltd. - www.serif.com

Share this post


Link to post
Share on other sites

Thanks. I'll just delete and recreate the styles. Only the TOC 1 style is affected right? So just delete that 1 in both docs?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.