Jump to content

Batch conversion to JPEG darkens image

Recommended Posts

Hey there,

I have trouble using the batch conversion.

Steps to reproduce:

1. Open Affinity Photo, File > New Batch Job (not sure if thats the term used in English, its the 8th item)

2. Select some RAWs, I tested it with Canons CR2, select "Save as jpeg"

3. Start the job


The following picture is a comparison in Windows Photos App, but I tried many different viewers. I didn't do editing to eliminate any other factors.

On the left: JPEG "manually" exported from Affinity Photo (Opening the RAW file, developing, exporting) "Highest quality"-preset
On the right: JPEG from batch conversion, similiar settings to "Highest quality"-preset: Quality: 100

What I tried:

- Embed the ICC-profile or don't, result doesnt change
- Different profiles don't change the result
- Convert to sRGB as macro, result doesn't change



There was an error uploading the files, so I had to make a screenshot, but I'll try again! Of course, I can also provide you with the RAW-file, but I think you should be able to reproduce the problem.





PS: I also found this thread: https://www.dpreview.com/forums/thread/4252273 , where a user has the same problem, but sadly no solution...

Edited by Franzus

Share this post

Link to post
Share on other sites

I run a lot of batch conversions, but typically from afphoto files, and I havent noticed that.  My workflow typically goes: Canon DPP to convert RAW to TIFF (16 bit), then batch convert in AP to afphoto, edit, then convert to JPEG. If you have Canon DPP available, Id convert a RAW file there, then see if the batch processor changes exposure.  If it doesnt, then bug confirmed.

Share this post

Link to post
Share on other sites



the behaviour of DPP 4 is as expected. The exported pictures are the same color / brightness:

(Exported by Canon Digital Photo Professional 4, maximum quality)


It doesn't seem to be limited to the JPEG-export, when I export as TIFF, the picture is also darker. It seems like one processing step that Affinity uses, when loading a RAW-image "by hand", is not applied when using batch processing.


Now the upload is working, so here is the RAW-file:



I would like to hear from someone if he gets the same result. I tested it on three different devices, so it should be easy to reproduce.

Edited by Franzus
Downsized image

Share this post

Link to post
Share on other sites

Welcome to the Serif Affinity forums, Franzus.

Batch processing uses a simpler raw development process than the Develop Persona uses. Typically the result is darker images, but there will be other differences, too, as none of the Develop Assistant processing is done. You can compensate for that, to some extent:

  1. Open a raw image from your camera with Affinity Photo, and develop it in the Develop Persona.
  2. Process the same image through a batch job in Photo.
  3. Open the image from step 2, and compare to the image from step 1.
  4. Determine a set of adjustments to make to the step 2 image to make it satisfactory to you, and record those adjustments as a macro.

Then, when you run your raw images through a batch job, apply that macro. Your results should be more satisfactory, though perhaps not completely right.

-- Walt

Windows 10 Home, version 1903 (18362.239), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo and Beta   / Affinity Designer and Beta  / Affinity Publisher and Beta

Share this post

Link to post
Share on other sites


thank you for your explanation. Even though I would think, that recording a macro is a workaround, but not the way batch processing should be handled!


I've been using Darktable, Lightroom, Photoshop and Canon DPP and they all convert my RAWs without any excessive changes. Only Affinity looses around half the brightness! I hope it is consistent atleast, then one macro should do the job.

Otherwise I'll have to stick to using Darktable or Canon DPP.


Thanks again, I'll try using a macro.

Edited by Franzus

Share this post

Link to post
Share on other sites

Hey Franzus,

It looks like the batch process isn't applying the same adjustments to the image that the Develop Persona would normally do. I would say that right now, this is by design but I am waiting to hear if there is a possible improvement we could make here.

Once I hear back from the developers, I will let you know.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now