Jump to content

Recommended Posts

Affinity P and D both keep lagging, locking up, and crashing.  Everything has been working flawlessly and the past week or two I’ve been working on the same photo manipulation and can’t get it done. The last update seems to have completely made my software unusable. Very frustrated, as are many other iPad Pro users 2017 & 2018 versions; mostly 2018. Many others are having the same issues with this iPad Pro 3rd gen.

I’ve tried hard reset several times, closing-shut down-and still crashing when making my selection of the photo I want to change.  I’ve tried several other files and it’s happening on all of them.

can you please put out an update to fix this issue?

Share this post


Link to post
Share on other sites

i am working with the newest iPad Pro 12.9 and affinity photo 1.7.2 and I haven't got any problems so far. keeping the filesize to original file size of the Fotos so about 30x45 cm. Even runs smoothly with up to 10 layers. How large are you fotos?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.