Jump to content

Recommended Posts

I have difficulties in having the supposed text overflow displayed in a document. This morning I wanted to export a PDF from a created document. Affinity Publisher showed me a window. According to this, text overflow should occur in at least one frame. But I can't find a red eye or any other red hint in the text containers. Only when clicking on the boxes for the page numbers created on the master page, red dots appear, however, additional text except "Nr." is not to be found also in this frame. I am a little perplexed.

 

Share this post


Link to post
Share on other sites

check again with the "text show special characters"activated: one of those characters might be outside the frame: like § end text flow character that normally is not visible

 

Share this post


Link to post
Share on other sites

Thanks for the hint, but there was nothing to see. Apparently it was annoying that the frames for the page numbers on the master page were a bit higher than the text containers. After the frames for the page numbers had been deleted, no more error messages appeared. But there was definitely no text overflow.

Share this post


Link to post
Share on other sites
6 hours ago, deister fox said:

I can't find a red eye or any other red hint in the text containers. Only when clicking on the boxes for the page numbers created on the master page, red dots appear, however, additional text except "Nr." is not to be found also in this frame. I am a little perplexed.

2 hours ago, deister fox said:

there was definitely no text overflow. 

Possibly you haven't seen the red markers because of your zoom view in your documents window. It sounds magic but it works to zoom out to make the red dots larger, relative to the page size. For instance on this page in 15% versus 85%. Also consider that other layout items do attract your eyes automatically when looking for the markers.

1847735696_textoverflow15zoom.jpg.fe54d94b900d13100708d97ebcbeea79.jpg     120692071_textoverflow85zoom.jpg.1f530b5e9313d06e076eae82d36acbb4.jpg


Especially fields (as # in page nr) on master pages might make it easy to have their frame set to a size which would not fit to its content on document pages becaus the field symbol can be much shorter than the real content. Therefore you don't get red dots for the frames in the sample above when looking on them on their Master page:

2112182890_Bildschirmfoto2019-08-31um12_04_08.jpg.0ae2a8fa83478514275c09778c262396.jpg

But even without red dots here you can see by the 'special characters' (as mentioned above by KnikmanAV) that the text frames 2 and 3 will create red dots because of their overflow which happens just by the paragraph break . In frame 3 made more obvious after clicking the eye icon at its right edge to unhide the § which is overflowing here (though the red dots above got generated by the amount of numbers in the frames)

 

 


macOS 10.12.6,  Macbook Pro 15" + Eizo 24"

Share this post


Link to post
Share on other sites

The "red dots" are only present if one has View > Show Text Flow enabled. Without that option enabled it is very difficult to find overflows.

(Note, too, that it is possible for an overflow to occur on a Master Page, and to only be visible if one looks specifically at the Master Page.)


-- Walt

Windows 10 Home, version 1909 (183623.476), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.3.481 and 1.8.0.514 Beta   / Affinity Designer 1.7.3.481 and 1.8.0.514 Beta  / Affinity Publisher 1.7.3.481 and 1.8.0.518 Beta

Share this post


Link to post
Share on other sites
3 hours ago, walt.farrell said:

The "red dots" are only present if one has View > Show Text Flow enabled. Without that option enabled it is very difficult to find overflows.

Call me crazy, but somehow that does not surprise me very much. xD


Affinity Photo 1.7.3, Affinity Designer 1.7.3, Affinity Publisher 1.7.3; macOS High Sierra 10.13.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.7.3.155 & Affinity Designer 1.7.3.1 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 13.1.2

Share this post


Link to post
Share on other sites

Same here.. tried everything but can't find any text frame with overflow. There are no red dots showing when zooming out (and yes my "Show Text Flow" option is on). There were some text frames that didn't had any text, but after I checked the document 4 times I'm pretty done with this.. :37_disappointed:

When trying to print an error is following. When clicking on "Ignore and continue" the print box appears. After I choosed the printer and clicked on "print", Affinity Publisher crashes and need to restart. My colleague has exactly the same problem. (Mac)

The only way to get it printed is to create an PDF first.

Schermafbeelding 2019-09-03 om 10.18.49.png

Share this post


Link to post
Share on other sites

Hi Muontania :)

28 minutes ago, Muontania said:

After I choosed the printer and clicked on "print", Affinity Publisher crashes and need to restart.

This isn't related to your overflowing text frames, this is a bug our developers are aware of and we're working to fix this asap.

This crash occurs when you have an embedded document which contains a different colour space/ICC profile than the main document. Do you have a placed document or image in your design? If so, please double click this element, then go to File>Document Setup and change the colour space & profile to match your main document. I hope this helps!

Share this post


Link to post
Share on other sites

I had this issue crop up as well. So I made several tables that were taller than my page, and then manually split them up to fit by deleting rows. Even though none of the now baby tables have overflowing text, the overflow text warning keeps coming up. As a test I deleted all the baby tables one by one and as soon as the last one is deleted the warning goes away.

Share this post


Link to post
Share on other sites

Hi Dimathiel,

Welcome to the forums :)

Could you please redo your deleted steps so your tables are still in your document, then upload a copy of this .afpub file here? Many thanks!

Share this post


Link to post
Share on other sites
1 hour ago, mrbips said:

Having same issue. Cannot for the life of me figure out what is "overflowing" 

Do you have View > Show Text Flow enabled. If so, you should be able to see the red dots on any text frame that has overflowing text, assuming the frame is tall enough. Zooming out so you have a lot of pages visible will make them more obvious. If you don't see them in the zoomed-out view, also check your Master Page(s).

If the file is not confidential and you can post it here, we can help you look. Or Serif can provide a private upload link if necessary.


-- Walt

Windows 10 Home, version 1909 (183623.476), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.3.481 and 1.8.0.514 Beta   / Affinity Designer 1.7.3.481 and 1.8.0.514 Beta  / Affinity Publisher 1.7.3.481 and 1.8.0.518 Beta

Share this post


Link to post
Share on other sites
On 8/31/2019 at 6:33 AM, thomaso said:

Possibly you haven't seen the red markers because of your zoom view in your documents window. It sounds magic but it works to zoom out to make the red dots larger, relative to the page size. For instance on this page in 15% versus 85%. Also consider that other layout items do attract your eyes automatically when looking for the markers.

1847735696_textoverflow15zoom.jpg.fe54d94b900d13100708d97ebcbeea79.jpg     120692071_textoverflow85zoom.jpg.1f530b5e9313d06e076eae82d36acbb4.jpg


Especially fields (as # in page nr) on master pages might make it easy to have their frame set to a size which would not fit to its content on document pages becaus the field symbol can be much shorter than the real content. Therefore you don't get red dots for the frames in the sample above when looking on them on their Master page:

2112182890_Bildschirmfoto2019-08-31um12_04_08.jpg.0ae2a8fa83478514275c09778c262396.jpg

But even without red dots here you can see by the 'special characters' (as mentioned above by KnikmanAV) that the text frames 2 and 3 will create red dots because of their overflow which happens just by the paragraph break . In frame 3 made more obvious after clicking the eye icon at its right edge to unhide the § which is overflowing here (though the red dots above got generated by the amount of numbers in the frames)

 

 

Zoom out trick worked for me. THANK YOU!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.