Jump to content
DM1

Inpainting tool misalignment - bug?

Recommended Posts

Was using the inpainting brush to fix an old b/w photo and after applying a live perspective filter to correct vertical distortion I found that inpainting no longer matches where screen touched. Is this a bug or simply the effect of the live perspective filter? Just seems odd.


IPad Pro 10.5/512GB lpadOS 13.1.3  Affinity Photo 1.8 Affinity Design 1.8 Publisher for iPad ?

Share this post


Link to post
Share on other sites

Just surmising here, but your setting is on ‘current layer’.  What if the filter is acting on the image layer, but is still separate or not yet part of the image, and you work on just that layer, would it not work sans the perspective filter?

Try turning on ‘current and below’ and see what happens.

Share this post


Link to post
Share on other sites

 

20 hours ago, DM1 said:

Was using the inpainting brush to fix an old b/w photo and after applying a live perspective filter to correct vertical distortion I found that inpainting no longer matches where screen touched. Is this a bug or simply the effect of the live perspective filter? Just seems odd

This is also the case on the desktop version,so either rasterise after applying the live perspective filter,which defeats the  nondestructive part of the live filter.*
or use the inpainting tool before one applies the live perspective filter.

 

1 hour ago, p_mac said:

Try turning on ‘current and below’ and see what happens.

Doesn't make a difference

*WorkAround

Switch of the visibility for the live perspective filter (sub)layer in the layers panel>start inpanting on the pixel layer and when done>switch on the visibility for the live perspective filter layer in the layers panel.
This is for the desktop version,don't know if this applicable in the Ipad version.


-------------------------------------------------------------------------------------------------------------------------------
Win10(1909)Home / Photo / Designer / Publisher & latest (beta) versions

Share this post


Link to post
Share on other sites

I agree, plenty of workarounds, merge visible, turn off perspective layer both work. I merely wish to know if this is expected behaviour (by design), or a form of bug?


IPad Pro 10.5/512GB lpadOS 13.1.3  Affinity Photo 1.8 Affinity Design 1.8 Publisher for iPad ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.