Jump to content
red.foxx15

Designer crashes in the middle of using vector brush

Recommended Posts

I Haven't found any consistency other than its only on the Mac version of the app. I don't have this issue with the same version on the Windows app.

 

Share this post


Link to post
Share on other sites

Hi Red.foxx15,

The crash you've attached is for Affinity Photo - however the Vector Brushes are only in Designer. Do you have the crash report for Designer (ideally the contents of the one that appears after the crash, prior to sending it to Apple). Are you able to try and capture you reproducing the crash on using a screen recorder please? 

Also what brushes are you using when it happens, does it happen on a new document or is it specific to the document you're working on? Would you be able to attach a copy of the brushes you're using and the document if possible please.

Share this post


Link to post
Share on other sites

Thanks very much for the file. Do you tend to use the [ or ] keyboard shortcuts to adjust the brush size whilst painting? I've managed to get a very similar crash by doing that, but again haven't been able to reproduce it since. I'm going to pass both this and my crash report on to development to see if that gives any hints as to what might be happening.

Share this post


Link to post
Share on other sites
Just now, red.foxx15 said:

sorry for the late response. Yes I do adjust my brush sizing using those keys.

Do you do that whilst in the middle of drawing a stroke? If so it could be that, that is causing the crash. If so could you try not doing that in the middle of the stroke and see if that helps to avoid the crashing!

Share this post


Link to post
Share on other sites
Just now, Sean P said:

Do you do that whilst in the middle of drawing a stroke? If so it could be that, that is causing the crash. If so could you try not doing that in the middle of the stroke and see if that helps to avoid the crashing!

not its not while in the middle of drawing a stroke, its always in between strokes 

Share this post


Link to post
Share on other sites

I'm having a similar problem so will piggy-back onto this post. Designer on MacOS crashed three times yesterday and today with (so far) no noticeable pattern. The last crash happened while I was setting "Color" for a vector brush on a new ArtBoard. The crash report is attached.

Affinity Designer_2019-09-18-102007_DOUGLASs-MacBook-Air.crash


  • Affinity Publisher 1.7.3
  • Affinity Photo 1.7.3
  • Affinity Designer 1.7.3
  • MacBook Air,  macOS Mojave v10.14.6
  • Nikon D7100 with 18-135mm zoom

http://www.dojopico.org

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.