Jump to content
davidlower8

URGENT BUG - Delete key adding a space

Recommended Posts

The delete key is adding a space instead of a backspace (delete action). Happens inside both the artistic text tool and frame text tool. I can not repeat the bug unfortunately. It just randomly occurred in my document. I was copying tables into my document. Maybe that triggered the issue.

Thanks

I have the full version (most up to date version 1.7.2) .

Ok it is now 26/08/2019 and the bug has reappeared. This bug is really difficult to work with. Almost impossible to continue using the software. Here is a video of the bug in action. Please note I have the latest version. Also I have just noticed the arrow keys (ALL of the arrow keys) similarly add a space. So you cannot use the arrow keys to navigate. I hope this helps. Lastly I have also just noticed if you save your progress, quit the file and reopen, the bug disappears. So at least there is a simple walk around so that is great news.

https://www.loom.com/share/0fbc1258124d41c099d671dbe2f8890d

Share this post


Link to post
Share on other sites

It will be useful if you can identify what might be happening before this triggers, when it happened the second time were you also copying in tables?

I find it odd the key mappings would change, when this happens I assume you have no issue in other programs?

Share this post


Link to post
Share on other sites

I had exactly the same issue recently. Suddenly, any non-letter key (delete, erase forward, arrows) would add various kind of spaces or tabs, making edits quite impossible. I eventually closed down Publisher and restarted, and it went away. I had no similar issues in other opened programs. I cannot say what I was doing just before it started. Probably pasting some text from somewhere else.

APub 1.7.2, MacOS 10.14.6

Share this post


Link to post
Share on other sites
On 8/22/2019 at 11:12 AM, davidlower8 said:

The delete key is adding a space instead of a backspace (delete action). Happens inside both the artistic text tool and frame text tool. I can not repeat the bug unfortunately. It just randomly occurred in my document. I was copying tables into my document. Maybe that triggered the issue.

Thanks

I have the full version (most up to date version 1.7.2) .

Ok it is now 26/08/2019 and the bug has reappeared. This bug is really difficult to work with. Almost impossible to continue using the software. Here is a video of the bug in action. Please note I have the latest version. Also I have just noticed the arrow keys (ALL of the arrow keys) similarly add a space. So you cannot use the arrow keys to navigate. I hope this helps. Lastly I have also just noticed if you save your progress, quit the file and reopen, the bug disappears. So at least there is a simple walk around so that is great news.

https://www.loom.com/share/0fbc1258124d41c099d671dbe2f8890d

I am experimenting the same thing. 

I launch the app and start to work and the delete works fine. Then, all of the sudden instead of deleting it adds a space. This needs to be fixed urgently as it makes the app unusable. This started to happen after I updated to 1.7.2.

I am using an iMac 27 inches Late 2013. Mac OS Mojave 10.14.6.

Share this post


Link to post
Share on other sites

@Jon P Unfortunately I cannot recall a potential cause to this bug. I was working on multiple files at a time and switching between various apps. So I have no idea when it kicked in or what could have caused it.

Thanks

Share this post


Link to post
Share on other sites

To fix this we will need to reproduce it happening, I'll continue to have a look but any additional information as to what areas of the app are being used before this happens would be useful.

Share this post


Link to post
Share on other sites

Unfortunately, I'm seeing this also on Windows.  It seems that after some time of being opened and used, this problem crops up.  In my case, the delete key deletes the whole text frame even though I'm in text editing mode and backspace does as described above and adds what is like a space, but with a control character.  I close the application and restart and it is fine again for now.  I'll post again if I can determine the trigger for the change which presents the bug.

Share this post


Link to post
Share on other sites

I'm having the same problem. The first par of text in the column has a space at the beginning and I cannot remove it. There is no par indent specified in paragraph spacing. Not sure when it appeared but I was working on a table which overlaps the text columns with a text wrap but it's not near the random space problem.

Share this post


Link to post
Share on other sites

Hi,

This bug is back (when I say back probably better to say still present). I have been working on Publisher for the last hour and I have had to quit 3 times. I currently I have 3 documents open and I am editing in between. Two of the documents this error is occurring. I am still not able to reproduce, but boy is it annoying. Is anyone able to let me know if this has been identified by the team and/or being fixed that would be great? I am trying hard to replicate the scenario in which it occurs. At the moment it is completely random.

Thanks

Share this post


Link to post
Share on other sites

I'm not aware that we have a recipe yet.

With a bug that affects this many users we can normally work it out or someone stumble across a reproducible recipe. I suspect some combination of copy/paste or UI interactions that are normal but infrequent.

 

Share this post


Link to post
Share on other sites

chiming in - I have latest version Publisher, yes I was working in tables fine all day, and about an hour ago bug appeared exactly as described. hit delete / get a space. Not the first time for me either. My fix is shut down Publisher and re-open. Has anyone tried deleting preferences files? (yes I'm an old Adobe user).  Guess wouldn't matter as shutdown mandatory either way. Manually selecting extra spaces to key over them works thankfully, so keep on truck'n!

Good Hunting

Share this post


Link to post
Share on other sites

Follow-up to previous post on this, today I notice going back into a table with text tool to edit the table and viola! the delete key is functioning normally within the table. huh.

Next I clicked on the pasteboard to deselect the table tool, and selected the pointer select tool. Next I double clicked on some non-table text and the delete key is now functioning normally in and out of tables for me. Basically I kicked the tires.

Can someone experiencing the problem please verify this on their system and report back yea or nea?

Share this post


Link to post
Share on other sites

This will recreate the problem EVERY TIME.  Very frustrating.  Only way to go back to "normal" is to close down and relaunch.  I am sure there might be other ways to recreate it.  But basically, I make a table...set it the way I wanted...locked the layer....and placed a text box on top of it.... and started typing....  Only Caps will type...no backspace....Shift-7 will give you a 7 instead on a & sign.  Anyway...I hope this helps the developers and hopefully this is posted in the correct area.  

Share this post


Link to post
Share on other sites

Not sure if that’s the same problem, but if I press backspace in a text frame, Publisher changes the paragraph style. Forward delete works.

I didn’t (and would never) redefine backspace in keyboard shortcuts and couldn’t find anything there that would match this behaviour.

(This is Affinity Publisher 1.7.3 on macOS 10.14.6.)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.