Jump to content
ESP

Updates Affinity Designer - Not working on Mac

Recommended Posts

I have both Affinity Photo and Designer on my Mac.  Photo updates automatically but Designer has not.  When I go into Affinity Designer on the App Store it wants me to purchase again.  I do not have an Affinity account to check online, I purchased thru App Store. It shows that I'm still on version 1.6.1 How do I update this app?

Any help is appreciated.

Share this post


Link to post
Share on other sites

Hi ESP,

Welcome to the forums :)

Please try the following:

  1. Open the Mac App Store
  2. Log out of the store
  3. Restart your Mac
  4. Log back into the Mac App Store and go to Updates - if the update is still not showing please try using Store>Reload Page from the top menu.

If the app update is still not showing and you're being prompted to purchase the app, is it possible that Affinity Designer was purchased under a different Mac App Store login? 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.