Jump to content
Zeklandia

Designer crashes in Export Persona (Windows, Designer, 1.7.2.471)

Recommended Posts

This is happening on Windows 10 Pro 64-bit with Affinity Designer 1.7.2.471.

I have this one file that crashes Affinity Designer when switched to the Export Persona. I can manually export each Artboard fine in the Draw Persona.

It gets more complicated, though. I have this file link-embedded in several other files (Problem file > other files). Those other files can be switched to the Export Persona fine, but clicking on the Slices pane causes a crash. Exporting from the Draw Persona still works in those files.

But it gets weirder. I have one file in which I have link-embedded one of those other files with the problem file link-embedded (Problem file > other file > this one file). It does not cause crashes when switching to the Export Persona or using the Slices pane, and can successfully export all Slices as expected.

I have attached the problem file.

P.S. I know it isn't supposed to be possible to link embed files in Designer 1.7.2, but I needed it because I keep editing these files and link-embedding made replacing old versions much easier. When I needed to reload the link-embedded files, I would just open the file in Publisher and update it there.

Emblem.afdesign

Share this post


Link to post
Share on other sites

Hi Zeklandia,

Thanks for letting us know - there is a known issue after upgrading that is causing this crash. I've reproduced it and passed it on to development. In the meantime can you try launching the software with Ctrl held down. On the dialog that appears ensure only the first 3 boxes are ticked and then click 'Clear'. This should reset the studio back to default and allow you to access the Export Persona with the attached document without crashing.

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, Sean P said:

Hi Zeklandia,

Thanks for letting us know - there is a known issue after upgrading that is causing this crash. I've reproduced it and passed it on to development. In the meantime can you try launching the software with Ctrl held down. On the dialog that appears ensure only the first 3 boxes are ticked and then click 'Clear'. This should reset the studio back to default and allow you to access the Export Persona with the attached document without crashing.

I cleared those settings, and, while I can get to the Export Persona, it still crashes when I click on the Slices pane.

 

EDIT: I don't think resetting changed the situation. The different files all still crash at the same point (e.g., switching to Export Persona, activating Slices pane).

Edited by Zeklandia
Further information

Share this post


Link to post
Share on other sites

Thanks for getting back to us Zeklandia,

It is actually the Slices Panel that is causing the problem. What the Ctrl run up did (and why it apparently seemed to fix it) was to reset the Studio which would have made the Layers Panel visible instead of the Slices. I've updated the issue with development

Share this post


Link to post
Share on other sites

Yep, same issue here - clicking the Slices panel hangs AD. This is a fairly simple design with a couple of art boards and a linked SVG placed in it.

Share this post


Link to post
Share on other sites

Same here.  Came to this forum to post a similar message.   Created a simple banner with some curves, switched to Export persona and immediate hang.   Did the Clear trick as described above and successfully got to export, but as rsim says, clicking Slices tab hangs it again.

Not trying to be a jerk but I am starting to try and transition to AD instead of illustrator for design, so this is a little concerning.  Really like and appreciate the value of Affinity tools (I own all) but at the end of the day I have to be able to trust I can get work done!

Share this post


Link to post
Share on other sites

@BIOSMonkey

Welcome to the Serif Affinity forums  :)

To all readers,

Sorry about this regression I have escalated the issue to have it fixed in the next patch.

For those on tight deadlines please avoid the slices tab or if that's not possible revert to 1.7.1 from here (works as a trial for those who bought Affinity Designer from the Windows Store)


Patrick Connor
Serif (Europe) Ltd.

Latest releases on each platform 

Share this post


Link to post
Share on other sites

Same issues happen, i hope the developer decide to do a hotfix. Because this is part of crucial features for exporting .svg without bounding boxes

Share this post


Link to post
Share on other sites

Same here. Really hope it got patch soon.

Tried to copy a entire artboard to a new document, does not solve the problem... and tried around with opening it in affinity photos, no luck again...

 

Share this post


Link to post
Share on other sites

I know it's been already reported to the developers, but wanted to inform you that I ran into this problem too with my own AD document.

Share this post


Link to post
Share on other sites

Hi,

I've run into the same problem, situation:

1. New laptop (yesterday), HP Probook.

2. Fresh install of Affinity Designer

3. Document with multiple layers and symbols.

4. Export > Slice tab = crash.

Already tried the clear settings (CTRL at startup), but didn't help.

If the support Team needs an example of the file and/or system config that causes the problem, let me know.

 

* Just reverted back to 1.7.1.404 and reset settings and the same issue still occures.

Edited by _Dave

Share this post


Link to post
Share on other sites
On 8/22/2019 at 5:29 PM, Patrick Connor said:

@BIOSMonkey

Welcome to the Serif Affinity forums  :)

To all readers,

Sorry about this regression I have escalated the issue to have it fixed in the next patch.

For those on tight deadlines please avoid the slices tab or if that's not possible revert to 1.7.1 from here (works as a trial for those who bought Affinity Designer from the Windows Store)

Hi @Patrick Connor I am on a tight deadline here, I need the slices though. I reverted to 1.7.1.404 as advised (uninstalled 1.7.2 first) the problem is still here. clearing settings with "Ctrl" held down helped as you said by not showing Slices tab, switching to slices crashes Designer.

I made a new save with Save As to unlink the file from Publisher file it was linked to, it does not help.

EDIT: same thing with 1.7.0

EDIT2: same file (re-saved in Designer 1.7.0), if I go to "Edit in Photo" and go to Export persona of Photo (1.7.2) crashes Photo too.

Share this post


Link to post
Share on other sites
2 hours ago, Patrick Connor said:

Affinity Designer and Affinity Photo 1.7.3 Windows beta builds will be available tomorrow I think. I do not know why 1.7.1 is also crashing, sorry

2 hours ago, Nikola Kovac said:

@Patrick Connor thank you, Hope you manage it tomorrow or I'm in trouble.

I'm fairly astonished it has taken this long.   This is a critical application hang, easily repeatable and crippling to anyone trying to export their work.   All this time I have been lucky, I guess, that the main artboards I need to export are working, while a less important graphic crashes AD every time.

 

 

Share this post


Link to post
Share on other sites

Same issue here.

I found also a solution for this issue until will be fixed:
- Create a new document
- Select all the content from the problematic document with a selection box
- Copy and paste the content to the new document
Now, you should be able to switch to Export Persona without any problem in the new document.

Share this post


Link to post
Share on other sites
52 minutes ago, Radu F said:

Same issue here.

I found also a solution for this issue until will be fixed:
- Create a new document
- Select all the content from the problematic document with a selection box
- Copy and paste the content to the new document
Now, you should be able to switch to Export Persona without any problem in the new document.

Sounds good will try if the update does not come soon. Thank you!

Share this post


Link to post
Share on other sites

This is a real problem for me.

I create multiple (30 or more) title boards as artboards on a common Designer document for my video productions, and export them to individually named jpegs in one fell swoop using slices in the Export persona. I now have to export each board singly (manually renaming each one) direct from the Designer persona. This is painful.

Copying content into a new document as recommended above does not change the problem.

All the documents I have created so far trigger this bug.

(edit after downgrading)

I have just downgraded to 1.7.1.404 (you have to uninstall 1.7.2 first).

The file created in 1.7.2 crashes 1.7.1. BUT if I now make a new document and copy the artboards from the new version and save that, I can get into Export>Slices. 

So it looks like there's something in the 1.7.2 container that causes the crash, not the 1.7.2 program environment or the file's artwork content.

Please advise me where to find the 1.7.3 beta when it is released - if it fixes this bug.

Thanks - Alan

Edited by AlanH
added results of downgrading to 1.7.1...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×