Jump to content
Guy Alex

A bug in 1.7.2. version: masking groups of adjustments

Recommended Posts

As already reported under the PC version of Affinity Photo, there is a bug concerning the masking of groups of adjustments. The mask which should normally apply to the group of adjustments actually applies to pixel layers below. For details, I refer to posts reporting the bug in the PC version since it apparently behaves the same way on a PC and on an iPad. :(

Share this post


Link to post
Share on other sites

Hi there's a similar issue with the Mac version too, I tried to add a mask to a group and when I try to invert the mask layer, the image disappears and its just shows an empty transparent layer. Please refer the video below. Thanks.    

Share this post


Link to post
Share on other sites

@Chris B Is there any kind of support or is anyone responding to these posts.. any other way I can get a solution to this problem ? Its so weird.. If anyone could help with this issue, kindly help before I regret buying Affinity Photo..

 

Share this post


Link to post
Share on other sites

Well, the issue is dealt with by the developpers and we have to await their response and hope it will come quickly. 

On a PC you can go back to a previous version of the software, but once you have downloaded a new version on your iPad, I am afraid there is no way back and you (and me and many others) have to wait. (Maybe there is a solution that I just ignore and we can somehow return to the previous version.)

But don’t lose faith in this software. This bug is surely very unpleasant and our discontent understandable, but it will be resolved. For me this has been the first more serious issue I have detected (there have been a couple of minor ones). Though I am a “newbie” on this forum, I have used Affinity Photo since its introduction on the market. This is entirely without prejudice to my urging the developpers too. ;-)

Share this post


Link to post
Share on other sites
On 8/25/2019 at 12:07 AM, frezeo said:

@Chris B Is there any kind of support or is anyone responding to these posts.. any other way I can get a solution to this problem ? Its so weird.. If anyone could help with this issue, kindly help before I regret buying Affinity Photo..

 

Hi frezeo,

I should have made it clear from my initial reply that it has been logged with the developers as opposed to me just waiting for some feedback. Apologies for that.

I understand that we are looking into what has happened and I believe that this issue has been introduced as a result of us fixing something else. 

Can you try placing a temporary empty pixel layer in your group to see if this works around the issue?

 

Share this post


Link to post
Share on other sites
5 minutes ago, Chris B said:

Can you try placing a temporary empty pixel layer in your group to see if this works around the issue?

Alas, I do not think that will work

See this thread

https://forum.affinity.serif.com/index.php?/topic/96245-applying-a-mask-on-grouped-adjustment-layers-doenst-work-anymore/

 


Due to the fact that Boris Johnson is now our Prime Minister, punctuation, spelling and grammar will never be worried about ever again.  We now have far bigger problems to be concerned about.

Share this post


Link to post
Share on other sites

You may be right. We've seen a few other instances with Publisher where this 'workaround' hasn't actually worked :/ These findings have been added to the bug report but we're still waiting for the feedback.

Share this post


Link to post
Share on other sites

None of the 'workarounds' seem to work at all for me. I have had to create individual masks for each adjustment in order to make them work, as gouping them

and then duplicating the mask and assigning the duplicate to each adjustment fails to preserve the adjustment. Waiting for a fix. Thank you

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×