Jump to content

Recommended Posts

When I started Affinity Photo, I got a message saying that 1.7.2 was available.  I downloaded it and attempted to update.  Got the message Setup Failed.

When I then tried to start Photo, it was missing and couldn't start.

So I deleted the downloaded file and went to download it again but I cant find a link to download it.

I get the same New Version Available dialog with Designer and Photo but I'm not willing to take a chance on losing them also.

How do I download Photo 1.7.2?

Thanks, 

Dave Davis

 

Share this post


Link to post
Share on other sites

There was no need to delete the downloaded file, simply restart the computer and run it again. Now it's gone you can redownload it from this link or by following these instructions taken from the Photo Windows 1.7.2 launch announcement. You will probably still need to restart before the installer will work.

"If you’ve purchased from the Affinity Store— each time you start the Affinity Store software it will check for updates and offer any available update. The latest update will install over the top of any earlier version, with no need to uninstall. You can download the latest installer by logging into the affinity store here and find the order in your account and use the "Download" button in there. Alternatively, this new release (and previous versions of Affinity Photo for Windows) can be downloaded from this link. (that installer is NOT for Windows Store purchases and needs a product key)."


Patrick Connor
Serif (Europe) Ltd.

Latest releases on each platform 

Share this post


Link to post
Share on other sites

Okay, when I tried to Update Photo, Designer, and Publisher, all updates failed

image.png.d4d4c9bebf5559c285a7f8171ba6365c.png

and then when I attempted to access the previous version of the update that had failed, I saw this

image.png.6ff3c6a3a38c8acbaaf1f7850ee7f0fe.png

In each case, I was able to get things working with a restart of Windows.

I also note that when I initially attempted to Update, clicking on the update file began the process.

After the restart, clicking on the Update file brought up a dialog asking where I wanted to install.

I hope this will help anyone else having a problem with the update.

Kudos to Serif for getting back to me very quickly.  thanks guys.

Dave

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×