Jump to content
Joachim_L

Soft hyphen reduces letter spacing

Recommended Posts

31 minutes ago, matisso said:

Does it persist if you change the font? Perhaps something has been overlooked in the font file itself.

Correct, not all fonts do have this problem, but some like: Corbel, Milo, Gabriola, Minion Pro, Myriad Pro, Source Sans Pro and Tahoma. These are the ones I found in my installed fonts.

Share this post


Link to post
Share on other sites

That’s pretty odd, I would assume this would happen in rather poorly designed fonts. Maybe the reason is somewhere else, or maybe the ones you mentioned do have bugs (not entirely impossible). However,  given how popular Minion, Tahoma and Myriad are, it’s hard to assume no one else noticed it before using software other than Affinity, so maybe there’s indeed a glitch…

Share this post


Link to post
Share on other sites

Too much work. :D I add a screenshot instead. Apart from a few fonts recently added like Milo, LCD and some more coming from CS6, the fonts were already installed on a brand new Windows 10 PC.

 

fonts.jpg

Share this post


Link to post
Share on other sites

I can reproduce it with Tahoma. I've not tried anything else. It happens because the font gives the soft hyphen character (U+00A0) the same glyph index as a normal hyphen (U+002D). It then kerns 't' with the normal hyphen's glyph index, effectively specifying that 't' kerns with soft hyphens. Arguably the font should not give soft hyphens any outline at all; we already have code that prevents them being drawn, but they were still being passed to the OpenType engine.

Looking into this I've found several other issues where kerning or other OpenType rules are affected by things they shouldn't be. For example, if you have an index mark between "AW" it won't kern. If between "fi" it won't form a ligature. A floating object pin will also make a difference.

I've logged this to be fixed in a future update. Thanks for reporting it.

Share this post


Link to post
Share on other sites
8 hours ago, Dave Harris said:

I can reproduce it with Tahoma. I've not tried anything else. It happens because the font gives the soft hyphen character (U+00A0) the same glyph index as a normal hyphen (U+002D).

That was part of the "common thread" I was seeing - the multi-mapped glyphs.

Also take a look at Source Sans Pro where it is not multi-mapped but the softhyphen is using the metrics from the hypheminus.
Per above this also causes this issue.
:)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.