Jump to content
Sarah Yuster

Healing brush not responding in Mac OS

Recommended Posts

I've tried using the healing brush ( which has worked most of the time before) on Affinityphoto images, NEF raw files, TIFF and jpg. It seems to be operative in that it lets me select the tool, asks for a "click option" but then no changes appear where I drag the cursor.

Share this post


Link to post
Share on other sites

Welcome to the forum Sarah Yuster.
One mistake that I keep making on a pretty regular basis in Photo is not having the correct layer selected which means that the tool I am using is operating on a layer on which it has no effect. Or, the tool is affecting a layer but it’s part of the layer that is not visible which has the same visual result.
Have you checked that you have the correct layer selected and, if you also have an active selection, you are using the tool within that selection? It’s so easy to get this wrong – for me at least – that it comes up almost every time I use Photo.

Share this post


Link to post
Share on other sites

thank you for replying! I am not sure what layer should be in use. Maybe I accidentally changed the settings from the ones that had been working for me. the color and light adjustments are working though. since you've been helpful (by the way, I looked at the tutorial and it didn't offer any definitive info in this regard), can you tell me what the layer box should say? in the meantime, I'll experiment.

Share this post


Link to post
Share on other sites

Hi Sarah Yuster,
Welcome to Affinity Forums :)
Also check if you have the Opacity or Flow of the brush set to 0% in the context toolbar. If so change them to 100%.

Share this post


Link to post
Share on other sites

yes, I have them at 100%.  Nothng in the touchup or paint is responsive although the right hand panel with light and color adjustment works. Can you see if I screwed something up in this screenshot? ( and thank you!)

Screen Shot 2019-08-15 at 11.02.07 AM.png

Share this post


Link to post
Share on other sites

You have a Vibrance Adjustment selected. These tools only work with a pixel layer (check the label between parenthesis after the layer's name in the Layers panel). If you switch to the background layer (which is a pixel layer) the tools will work as you'd expect. These live adjustment (and filter) layers should only be used in conjunction with (some of) the brush tools when you want to edit/manipulate their built-in masks (so you can hide their effects on some parts of the image if you paint with black on them or paint with their effects in case you invert the mask and paint with white)

Share this post


Link to post
Share on other sites

well,

I don't know how I did that, but I'm sure you deal with people like me frequently. Yes, the healing brush is working and I expect the painting tools will too. I'm a painter, not a photographer though I do need to use good cameras for reference and creating repro quality files. Lots to to learn.

Thank you!!!

Share this post


Link to post
Share on other sites
12 minutes ago, Sarah Yuster said:

I don't know how I did that

I do! ...and don't worry this happens to me all the time and I've been in the graphics industry for about 25 years! When you add any adjustment layer then it automatically gets selected, which enables you to imediately use a brush tool or gradient tool to amend the way the adjustment layer affects your picture. It's very slightly counter intuitive and is always catching me out, however, the more it does it the more I learn to look at the layers first to make sure I'm on the pixel layer, so it's slowly sinking in.

Lovely painting by the way!

Share this post


Link to post
Share on other sites

I feel better now! Born with an inherent distaste for following directions as well as a nagging fear that I'm incapable of doing so anyway, I've been forced to carefully learn what's essential for my line of work.  It's as psychologically wresting and tortuous as painting itself can be.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.