Jump to content
Sign in to follow this  
All Media Lab

Crop problem still not fixed!

Recommended Posts

Hi,

Downloaded the Beta of Affinity Photo to check if the crop tool was fixed but unfortunately not! When I try to crop an image the crop is far above and beneath the image and I have to scroll up and adjust and scroll down and adjust and this for every image I have to crop. In the old version of Affinity Photo this worked perfect and the crop tool was placed at the top and bottom image border like it should.

How long do we have to wait to get this fixed or is this going to stay? Don't understand the idea behind it! It's just a bad work flow!

Regards,

David

Share this post


Link to post
Share on other sites

What mode of crop are you using, and can you provide a screenshot?


-- Walt

Windows 10 Home, version 1903 (18362.239), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.2.471 and 1.7.2.464 Beta   / Affinity Designer 1.7.2.471 and 1.7.2.4464 Beta  / Affinity Publisher 1.7.2.471 and 1.7.3.475 Beta

Share this post


Link to post
Share on other sites

If you change preferences the problem will not be a problem anymore.

Preferences => Tools => Check "Use mouse wheel to zoom"

You will see how easy the cropping now will be.

Regards,

Peter

 

Share this post


Link to post
Share on other sites

And here is an other video with a crop on the old version of Affinity Photo. This is on version 1.65.123

Notice that the crop is perfectly aligned with the top and bottom of the image. No scroll needed! This is how it's supposed to be working!  

Share this post


Link to post
Share on other sites
11 minutes ago, PetervL said:

If you change preferences the problem will not be a problem anymore.

Preferences => Tools => Check "Use mouse wheel to zoom"

You will see how easy the cropping now will be.

No unfortunately when I do a 1:1 crop with your settings in the preferences it's still above and beneath the image and I have to scroll! 

The issue is the fact that the crop tool doesn't align with the image top and bottom anymore. Just watch the 2 video's and see what i mean!

Share this post


Link to post
Share on other sites

Now, while doing your 1:1 crop, with one stroke of the mouse wheel you have your image setup for the easy crop you're looking for :)

Share this post


Link to post
Share on other sites

I understand what you mean, but it used to crop in one click and align with the top and bottom of the image. When you have loads of cropping to do it's not workable how it is now.:) also not by zooming with the mouse wheel. In webdesign you use different ratios for art direction and it used to work instantly. I can not even create certain ratio's, because the save presets don't work proper. ( this is already reported by the way!).  

Share this post


Link to post
Share on other sites
1 hour ago, All Media Lab said:

it's still above and beneath the image and I have to scroll! 

No, you don't. You could just grab the node on the left side and drag it to the right. No scrolling needed, just 1 drag.

But you're right that it has changed, and I think the new behavior is probably a bug.


-- Walt

Windows 10 Home, version 1903 (18362.239), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.2.471 and 1.7.2.464 Beta   / Affinity Designer 1.7.2.471 and 1.7.2.4464 Beta  / Affinity Publisher 1.7.2.471 and 1.7.3.475 Beta

Share this post


Link to post
Share on other sites

Thanks for having a look at it Walt! That makes it a bit more easy, but it's still not the way it should be. How can I report this bug?

In the old version of Affinity Photo  I have made ratio's presets for phone portrait, tablet portrait , full screen etc and I can just pop them in and make art directions in only a click like I showed in the second video. In the new version it is a lot of extra work to get the same result including your node drag technique.

Regards, 

David

Share this post


Link to post
Share on other sites
1 hour ago, All Media Lab said:

How can I report this bug?

I believe it's not unique to the Beta, so you would create a new topic in Photo Bugs Found on Windows.


-- Walt

Windows 10 Home, version 1903 (18362.239), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.2.471 and 1.7.2.464 Beta   / Affinity Designer 1.7.2.471 and 1.7.2.4464 Beta  / Affinity Publisher 1.7.2.471 and 1.7.3.475 Beta

Share this post


Link to post
Share on other sites

I think the problem is that with 1:1 photo has to choose one dimension to start the crop and in this case is choosing the longest dimension, whether previously it chose the short dimension I do not know or if there is a setting to change the preference.

However if you click on rotate before applying the custom dimension it will crop the 1:1 to the shortest dimension

Share this post


Link to post
Share on other sites

Same problem on Mac, very annoying...


Affinity Publisher, Photo, Designer + Capture One & DxO Photolab on 2019‘ iMac 27“ 3,1 Ghz i5, Radeon pro 575X, MacOS Mojave

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×