Jump to content

Concave text frames don’t always show the text in the expected manner

Recommended Posts

Windows 10 Home 1903, Publisher
It will be easier for you to watch the attached GIF than me trying to explain what’s going on.
Workflow to replicate:
* Create a Rectangle;
* Convert it to Curves;
* Convert it to a Text Frame;
* Add Filler text;
* Give the Text Frame some Insets;
* (Optional: Give the text frame a background colour and the text a different background colour);
* Drag one vertex of the shape so the shape is significantly concave.
Note where all of the text except the first word disappears when the shape becomes significantly concave. The insets may account for some of the text going missing but there is more than enough space remaining to put more text.
I think it’s worth saying that I don’t think many people would want to actually do this but it’s possible.
The effect doesn’t always happen, it just depends on which vertex you drag. In my example, dragging either of the bottom two vertices seems to be fine but dragging either of the top two vertices shows the problem. (Dragging both the top two vertices together is also fine.)
I’ve tried this with Baseline on and off and get the same thing so that doesn’t seem to be a cause of the problem.


Share this post

Link to post
Share on other sites

I deliberately didn’t include an AFPUB file as the instructions were short and I wanted other users to try it for themselves with their own machines, settings, etc. to see what happens.
However, I’ve attached another example (with AFPUB) where the effect is even more visible. I can’t see the problem coming from there not being enough space I can clearly see that the text pops in and out depending on where the vertex is.



Share this post

Link to post
Share on other sites

Thanks. I'll look later, probably tomorrow.

My working theory is that your inset values are what causes this, because with them there's no room for the next word at some point when you move that vertex. And when there's no room the rest of the following text has to disappear.

To see what's happening you need to stop adjusting it exactly when the text disappears and measure to see if the next word should have fit.

Share this post

Link to post
Share on other sites

What I can see from the animations is, that there is no hyphenation. I guess if you turn it on the behaviour will change. In the second animation how should "pelentelesque," behave, it no hyphenation is turned on?

Share this post

Link to post
Share on other sites

Ah, I think I’ve found the problem and it’s a bit weird; it seems to only happen with Filler Text.
When I use filler text the problem is there but if I expand the field – to make the text ‘normal’ text – the problem goes away.
Attached is a sample where (purple shape is my approximation of the insets as Publisher has no Offset/Inset function for shapes):
* the top shows the filler text in a rectangular frame;
* the middle shows how the filler text wraps within a concave frame;
* the bottom shows how the expanded text field wraps normally.
I still think this needs to be looked at but it’s probably a minor issue as I can’t see many people wanting to do this on a regular basis.



Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.