Jump to content
MattP

Affinity Designer Customer Beta (1.7.2.2 - RC1) [BETA CLOSED]

Recommended Posts

This beta has been superseded by the release of Affinity Designer for macOS 1.7.2 to the public. Check back on this forum for future betas.

Status: Release candidate

Purpose: Features, Improvements, Fixes

Requirements: Purchased Affinity Designer

Mac App Store: Not Submitted

Download: Download link removed as 1.7.2 is now live

 

Hello,

We are pleased to announce the immediate availability of the first release candidate build of Affinity Designer 1.7.2 for macOS.

If this is your first time using a customer beta of an Affinity app, it’s worth noting that the beta will install as a separate app - alongside your store version. They will not interfere with each other at all and you can continue to use the store version for critical work without worry.

This beta is an incremental update to the 1.7.1 version recently released to all customers. We recommend that you use this beta in preference to the store version if you are affected by any of the issues listed below.

Matt

 

Changes Since 1.7.1

- Improved usability with Apple’s Sidecar for macOS Catalina and iPadOS 13. (This build is still not notarized, so requires user action to allow it to run)

- Grid gutters reinstated.

- ‘Edit all layers’ can now be used to allow/disable artboard object reparenting during translation drag/object creation.

- Fix for bleed export options.

- Fix for issues with constraints on children of constrained objects which are used as clips.

- Fix for failure to load SVG colour 'none' causing import to stop.

- Fix for pen tablet barrel rotation input turning the wrong way.

- General performance improvements.

- Text performance improvements.

- Added ‘d’ default keystroke to restore objects to black and white colours.

- PDF export improvements.

- Added TGA export.

- Different icon for beta builds.

- Added a warning when deleting a global colour.

- Fixed broken Japanese keyboard input (sorry!).

- Fixed printing CMYK documents on older versions of macOS.

- Fixed crash when reentering export dialog under certain conditions.

- Fixed crashes when pasting screenshots into the app.

- Fixed loss of legacy HSL adjustment HSV state after a save.

- Assorted small fixes and improvements.

- Help improvements.

- Localisation improvements.

- Import 16bit half float JPEG-XR files properly.

- Improved LAB colour conversions.

- Pantone palettes are now sorted alphabetically.

- Fixed crash when starting app in a folder containing weird characters.

Share this post


Link to post
Share on other sites
22 minutes ago, MattP said:

a folder containing weird characters.

Like in Walt Kelly's Pogo or Donald Westlake's Dortmunder books?


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.5

Affinity Designer 1.7.3 | Affinity Photo 1.7.3 | Affinity Publisher 1.7.3 | Affinity Designer Beta 1.8.0.2 | Affinity Photo Beta 1.8.0.163 | Affinity Publisher Beta 1.8.0.536

Share this post


Link to post
Share on other sites
1 hour ago, Old Bruce said:

Like in Walt Kelly's Pogo or Donald Westlake's Dortmunder books?

How dare you suggest that Pogo, Churchy, et al. are “weird characters”!! >:( :P whistling.gif


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.3.481 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.7.3.155 • Designer for iPad 1.7.3.1 • iPadOS 13.3 (iPad Air 2)

Share this post


Link to post
Share on other sites

Wow! No Mac customer Designer 1.7.2 beta for what seemed like forever ... & then Boom, we get RC1!! :)

Now I can finally try the 1.7.2. Publisher beta with both StudioLink personas. Yay!!


Affinity Photo 1.7.3, Affinity Designer 1.7.3, Affinity Publisher 1.7.3; macOS Mojave 10.14.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.7.3.155 & Affinity Designer 1.7.3.1 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 13.1.2

Share this post


Link to post
Share on other sites
Just now, R C-R said:

Now I can finally try the 1.7.2. Publisher beta with both StudioLink personas. Yay!!

It may work, but that may require another beta build of Affinity Publisher, for reasons too complicated to go into here


Patrick Connor
Serif (Europe) Ltd.

Latest releases on each platform 

Share this post


Link to post
Share on other sites
11 minutes ago, Patrick Connor said:

It may work, but that may require another beta build of Affinity Publisher, for reasons too complicated to go into here

Rats! I gave it a shot but while the Photo persona works with the Photo beta, the Designer one does not. :(

I did the usual launch of the AD beta & opened a file with it with the Pub beta not running, but no luck. I don't suppose restarting my Mac would make any difference, would it?


Affinity Photo 1.7.3, Affinity Designer 1.7.3, Affinity Publisher 1.7.3; macOS Mojave 10.14.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.7.3.155 & Affinity Designer 1.7.3.1 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 13.1.2

Share this post


Link to post
Share on other sites
1 hour ago, Patrick Connor said:

It may work, but that may require another beta build of Affinity Publisher, for reasons too complicated to go into here

StudioLink doesn't work for either Designer or Photo.  OK will just use MAS and store versions until new release comes. Thanks for all the hard work.

Share this post


Link to post
Share on other sites
3 hours ago, abarkalo said:

StudioLink doesn't work for either Designer or Photo.

StudioLink worked for me to enable the Photo persona of the 1.7.2.422 beta build of Affinity Publisher with the 1.7.2.147 build of the Affinity Photo beta installed, but not with the latest Photo 1.7.2.149 - RC1 build. So I guess there is something in the RC1 versions that the non RC1 version of Pub is not compatible with.

But for all 3 betas, the File > Edit in Designer/Photo/Publisher menu item works, which I suppose is something.


Affinity Photo 1.7.3, Affinity Designer 1.7.3, Affinity Publisher 1.7.3; macOS Mojave 10.14.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.7.3.155 & Affinity Designer 1.7.3.1 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 13.1.2

Share this post


Link to post
Share on other sites
22 minutes ago, R C-R said:

StudioLink worked for me to enable the Photo persona of the 1.7.2.422 beta build of Affinity Publisher with the 1.7.2.147 build of the Affinity Photo beta installed, but not with the latest Photo 1.7.2.149 - RC1 build. So I guess there is something in the RC1 versions that the non RC1 version of Pub is not compatible with

That is what I would expect, thanks for confirming your findings


Patrick Connor
Serif (Europe) Ltd.

Latest releases on each platform 

Share this post


Link to post
Share on other sites
32 minutes ago, Patrick Connor said:

That is what I would expect, thanks for confirming your findings

If there are to be any more Photo & Designer betas released that will not work with the then current Pub beta's StudioLink, perhaps that could be mentioned in the OP so people like me won't get their hopes up?


Affinity Photo 1.7.3, Affinity Designer 1.7.3, Affinity Publisher 1.7.3; macOS Mojave 10.14.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.7.3.155 & Affinity Designer 1.7.3.1 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 13.1.2

Share this post


Link to post
Share on other sites
16 hours ago, R C-R said:

If there are to be any more Photo & Designer betas released that will not work with the then current Pub beta's StudioLink

From what I understand of it, the implied compatibility of "StudioLink" seems to be:

  • Publisher Beta will only work with Photo Beta and/or Designer Beta
  • Publisher (released) will only work with Photo (released) and/or Designer (released)
  • It will usually NOT work unless the Publisher version is at least as new as the corresponding Photo and/or Designer versions
  • The Photo or Designer version must have been run at least once outside of Publisher before Publisher is started for it to detect those programs
  • For early 1.7.2 beta builds and earlier versions, applications must be in their original locations and have their original names.  For the Mac, they must be in the Applications folder.

Share this post


Link to post
Share on other sites
3 hours ago, mac_heibu said:

… and: All apps must not be placed outside the „Application“ folder or within a user created extra folder in the „Application“ folder, as far macOS is concerned.

Thanks, added a comment to that effect.

Share this post


Link to post
Share on other sites
3 hours ago, mac_heibu said:

and: All apps must not be placed outside the „Application“ folder or within a user created extra folder in the „Application“ folder, as far macOS is concerned.

Not so for this beta AFAIK (though it is true of the 1.7.1 builds and earlier 1.7.2 betas). The current betas and forthcoming 1.7.2 MAS and Affinity Store mac should be able to overcome this limitation.


Patrick Connor
Serif (Europe) Ltd.

Latest releases on each platform 

Share this post


Link to post
Share on other sites
3 hours ago, fde101 said:
  • It will usually NOT work unless the Publisher version is at least as new as the corresponding Photo and/or Designer versions

It is the "usually" part that makes it difficult for Publisher beta testers (well, at least me) to know if StudioLink is working properly in the beta or not. That's why I suggested that info should be included in each new beta build.


Affinity Photo 1.7.3, Affinity Designer 1.7.3, Affinity Publisher 1.7.3; macOS Mojave 10.14.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.7.3.155 & Affinity Designer 1.7.3.1 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 13.1.2

Share this post


Link to post
Share on other sites

Not  big deal, but is there any possibility of seeing the addition of a Magic Wand/Flood Select Tool in Designer's Pixel Persona for the next update?

I would add this in under "Feature Requests", but because it's available in Designer for iPad I thought it may have mistakenly been overlooked for Designer for desktop.
Never thought I'd miss it much, but in its absence I have been finding myself switching to Photo purely for using the Flood Select Tool, which can become a bit tedious.

Share this post


Link to post
Share on other sites

Is Symbol sync problem (combination with global colors) still important at all? For about 3 years there are still no improvements?

Symbols breaks after editing Global Colors !!! (and in some other situations.)

any solutions or workaround available?

Thank you

 

Edited by Avestaman
Video added + some Links

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.