Jump to content

Recommended Posts

Posted (edited)

image.thumb.png.b7aa07b73da7b38fc0a04526f36e3e9d.png

(on Fedora 30, Affinity 1.6.5.135)

 

Information
I tried to run Affinity previously, but only got to the point of "VK_CHILD_WINDOW_RENDERING" not being implemented and after not using Affinity Photo for a long time to stay with Linux I got the following message on Discord:

image.thumb.png.54e95c55fadd09b30cd8568d0af1e4d4.png

So I had to try it out and what can I say? It works flawlessly!

 

Installation
Download Affinity 1.6.5 from: "https://store.serif.com/de/update/windows/photo/1/"
The following commands are required to install and use Affinity Photo (Run EVERYTHING in the same terminal instance).
Open a terminal in the same folder, you downloaded Affinity into!

# Download and extract the correct wine version
curl -L https://lutris.nyc3.cdn.digitaloceanspaces.com/runners/wine/wine-lutris-vkchildwindow-4.12.1-x86_64.tar.xz > wine-lutris-vkchildwindow-4.12.1-x86_64.tar.xz
tar xf wine-lutris-vkchildwindow-4.12.1-x86_64.tar.xz

# Set the path to wine for winetricks to work correctly
export WINE="$PWD/lutris-vkchildwindow-4.12.1-x86_64/bin/wine"

# Remove the old wine prefix
rm -rf ~/.wine

alias wine=$WINE
wine wineboot -i

When this window opens, click on "Cancel"

image.png.96736b5d3aa44052c5a9fb0187370ee3.png

# Downloading the newest version of winetricks
curl -L https://raw.githubusercontent.com/Winetricks/winetricks/master/src/winetricks > winetricks
chmod +x winetricks

Now that everything is downloaded, and a new prefix was created, you have to install some dependencies.
Follow the instructions in the setups and click on "Reboot Now". You can ignore warnings by the setups.

# To prevent errors from mono
./winetricks remove_mono -q
# For the installer
./winetricks dotnet35sp1 -q
# For the main application
./winetricks dotnet472 -q
# Set windows to 8.1, since aero is not found if set to win7
./winetricks win81 -q

Run the installer with: (Deselect desktop shortcut)

wine affinity-photo-1.6.5.135.exe

Install DXVK to make Affinity Photo work

git clone https://github.com/doitsujin/dxvk
./dxvk/setup_dxvk.sh install

Affinity should now be installed under "~/.wine"

 

Desktop Shortcut
Run this code below!

cd ~/.local/share/applications/
echo "[Desktop Entry]" >> "Affinity Photo.desktop"
echo "Name=Affinity Photo" >> "Affinity Photo.desktop"
echo "Exec=$WINE '/home/$USER/.wine/drive_c/Program Files/Affinity/Photo/Photo.exe'" >> "Affinity Photo.desktop"
echo "Icon='/home/$USER/.local/share/applications/$(ls ../icons/hicolor/256x256/apps | grep Photo | head -n 1)'" >> "Affinity Photo.desktop"
echo "Type=Application" >> "Affinity Photo.desktop"
echo "Categories=Photo;Utility;" >> "Affinity Photo.desktop"

 

Edited by toluschr
Fixed: downloading runner not working

Share this post


Link to post
Share on other sites

Hi

For info this does not appear to work!  To be exact the curl command to get the wine tar file point to a file that either does not exist or is protected in some way which prohibits download.

Shame really but there you go - save anyone else wasting a couple of hours trying to work out why they can't extract the tar file :(

Share this post


Link to post
Share on other sites

I am so sorry that the download link is broken. I tested it and it worked on the day I created the post. I will update it as soon as I have time!

Share this post


Link to post
Share on other sites

Thanks for the update - the new link worked :-)

However (and I think this is my system)  I cannot get the Affinity installer to run.
Would be interested if anyone gets it to work on LUbuntu 18.0.4 and if so what packages need installing after a fresh install.

Share this post


Link to post
Share on other sites
Posted (edited)

Hello. I use KDE NEON 18.04 (Ubuntu + KDE). I can't install dependencies with winetricks. The windows of installation are very small. I attach capture:

 

 

Capture.png

Help me? Thanks!

On 7/28/2019 at 1:09 PM, toluschr said:

wine wineboot -i

Edited by ssergio-ll

Share this post


Link to post
Share on other sites

Hi, when i try install Photo / Designer 1.6.5 i got SetupUI crash. on Last version 1.7.x working good , but when i wanna do something on canvas i got crash.
 

Summary : 1.7.x Work but can work on canvas. 1.6.5 don't wanna install (wine affinity-xxx.exe) crashing SetupUI . All installed.

 

nhandled exception: 0xe0434352 in 32-bit code (0x7b452e8c).
Register dump:
 CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
 EIP:7b452e8c ESP:0032e5e4 EBP:0032e658 EFLAGS:00000216(   - --  I   -A-P- )
 EAX:0032e5fc EBX:00000000 ECX:00000010 EDX:0032e6d0
 ESI:0032e6d0 EDI:00000001
Stack dump:
0x0032e5e4:  22006792 01695b48 01695b48 0012fca0
0x0032e5f4:  00001302 072ba300 e0434352 00000001
0x0032e604:  00000000 7b452e8c 00000005 88980406
0x0032e614:  00000000 00000000 00000000 008c0000
0x0032e624:  00000000 01695b48 00000005 00000000
0x0032e634:  00000000 0012fca0 0032e724 00000001
Backtrace:
=>0 0x7b452e8c in kernel32 (+0x22e8c) (0x0032e658)
  1 0x00a15383 EntryPoint+0x13c782() in clr (0x0032e704)
  2 0x00a15588 EntryPoint+0x13c987() in clr (0x0032e7cc)
  3 0x05943ee5 (0x0032e7fc)
  4 0x06399a9a (0x0032e998)
  5 0x0639ddb4 (0x0032e9f8)
  6 0x0639dbbd (0x0032eab4)
  7 0x0639586a (0x0032eacc)
  8 0x05440e5b (0x0032eb0c)
  9 0x05440d9b (0x0032eb2c)
  10 0x05440c75 (0x0032eb48)
  11 0x053efebd (0x0032eb84)
  12 0x04bcc4f7 (0x0032ebd8)
  13 0x04bc85fb (0x0032ec24)
  14 0x0038d08e (0x0032ec58)
  15 0x7e760bfc in user32 (+0xa0bfb) (0x0032ec88)
  16 0x7e76118d in user32 (+0xa118c) (0x0032ecc8)
  17 0x7e763585 in user32 (+0xa3584) (0x0032ed18)
  18 0x7e71f91e in user32 (+0x5f91d) (0x0032ed88)
  19 0x7e7258ea in user32 (+0x658e9) (0x0032ede8)
  20 0x7e725b80 in user32 (+0x65b7f) (0x0032ee38)
  21 0x7e75eb6c in user32 (+0x9eb6b) (0x0032ef68)
  22 0x7e75d024 in user32 (+0x9d023) (0x0032efc8)
  23 0x7e171fb6 (0x0032f058)
  24 0x7e1731c3 (0x0032f188)
  25 0x7e173c79 (0x0032f1b8)
  26 0x7e7613c3 in user32 (+0xa13c2) (0x0032f218)
  27 0x7e71fa3d in user32 (+0x5fa3c) (0x0032f2e8)
  28 0x7e72835a in user32 (+0x68359) (0x0032f338)
  29 0x056e02af (0x0032f384)
  30 0x056e01e6 (0x0032f3a0)
  31 0x056e0085 (0x0032f3e0)
  32 0x056cfdf4 (0x0032f434)
  33 0x056cf88e (0x0032f440)
  34 0x056cf7f6 (0x0032f44c)
  35 0x056cf5a7 (0x0032f468)
  36 0x056cef99 (0x0032f478)
  37 0x056cef5c (0x0032f484)
  38 0x03b1e9a5 (0x0032f498)
  39 0x008ceaf6 EntryPoint+0xffffffff() in clr (0x0032f4a4)
  40 0x008d1d50 EntryPoint+0xffffffff() in clr (0x0032f4f8)
  41 0x008d7764 EntryPoint+0xffffffff() in clr (0x0032f560)
  42 0x009493f0 EntryPoint+0x707ef() in clr (0x0032f68c)
  43 0x00949ad1 EntryPoint+0x70ed0() in clr (0x0032f900)
  44 0x009499b7 EntryPoint+0x70db6() in clr (0x0032fdf8)
  45 0x00949c9d EntryPoint+0x7109c() in clr (0x0032fe50)
  46 0x00949be3 EntryPoint+0x70fe2() in clr (0x0032fe90)
  47 0x00919d5c EntryPoint+0x4115b() in clr (0x0032fecc)
  48 0x1000d93b EntryPoint+0xffffffff() in mscoreei (0x0032ff08)
  49 0x79007f16 EntryPoint+0x50c1() in mscoree (0x0032ff18)
  50 0x79004de3 EntryPoint+0x1f8e() in mscoree (0x0032ff48)
  51 0x7b484480 in kernel32 (+0x5447f) (0x0032ffd8)
  52 0x7b481d5a in kernel32 (+0x51d59) (0x0032ffec)
0x7b452e8c: addl	$12,%esp
Modules:
Module	Address			Debug info	Name (57 modules)
PE	  400000-  582000	Deferred        setupui
PE	  8c0000-  fae000	Export          clr
PE	  fb0000- 10a5000	Deferred        msvcr120_clr0400
PE	 3b50000- 3bd0000	Deferred        clrjit
PE	 48d0000- 4a19000	Deferred        wpfgfx_v0400
PE	 4a20000- 4a98000	Deferred        msvcp120_clr0400
PE	 4aa0000- 4b6a000	Deferred        presentationnative_v0400
PE	 6050000- 6138000	Deferred        diasymreader
PE	10000000-1007d000	Export          mscoreei
PE	79000000-7904a000	Export          mscoree
PE	7a170000-7a175000	Deferred        d3dcompiler_47
PE	7a840000-7a849000	Deferred        opengl32
PE	7afd0000-7afd4000	Deferred        api-ms-win-core-winrt-string-l1-1-0
PE	7b160000-7b168000	Deferred        propsys
PE	7b430000-7b602000	Export          kernel32
PE	7b8b0000-7b8ba000	Deferred        wined3d
PE	7bc30000-7bc47000	Deferred        ntdll
PE	7be30000-7be35000	Deferred        d3d9
PE	7be80000-7be86000	Deferred        dwmapi
PE	7be90000-7be97000	Deferred        wintrust
PE	7bee0000-7bee7000	Deferred        dbghelp
PE	7bf70000-7bf93000	Deferred        wininet
PE	7c030000-7c035000	Deferred        odbccp32
PE	7c050000-7c055000	Deferred        mspatcha
PE	7c070000-7c075000	Deferred        imagehlp
PE	7c090000-7c094000	Deferred        sxs
PE	7c0c0000-7c0d4000	Deferred        urlmon
PE	7c350000-7c357000	Deferred        ws2_32
PE	7c390000-7c39d000	Deferred        mpr
PE	7c3c0000-7c3c6000	Deferred        uxtheme
PE	7c410000-7c415000	Deferred        cabinet
PE	7c440000-7c444000	Deferred        usp10
PE	7c4a0000-7c4f6000	Deferred        comctl32
PE	7c5f0000-7c5fa000	Deferred        aclui
PE	7c630000-7cf2b000	Deferred        shell32
PE	7d050000-7d054000	Deferred        dwrite
PE	7d570000-7d576000	Deferred        shcore
PE	7d5b0000-7d5f8000	Deferred        crypt32
PE	7d6a0000-7d6a5000	Deferred        bcrypt
PE	7d6c0000-7d6c5000	Deferred        rsaenh
PE	7d740000-7d74e000	Deferred        oleaut32
PE	7d860000-7d864000	Deferred        api-ms-win-core-xstate-l2-1-0
PE	7d870000-7d878000	Deferred        combase
PE	7dee0000-7def9000	Deferred        setupapi
PE	7e160000-7e165000	Deferred        winex11
PE	7e210000-7e21d000	Deferred        rpcrt4
PE	7e410000-7e414000	Deferred        api-ms-win-core-quirks-l1-1-0
PE	7e420000-7e424000	Deferred        api-ms-win-appmodel-runtime-l1-1-2
PE	7e440000-7e446000	Deferred        imm32
PE	7e480000-7e495000	Deferred        msvcrt
PE	7e550000-7e55e000	Deferred        gdi32
PE	7e6c0000-7e7b4000	Export          user32
PE	7e8e0000-7e8f2000	Deferred        shlwapi
PE	7e950000-7e95d000	Deferred        advapi32
PE	7ee50000-7ee68000	Deferred        kernelbase
PE	7efe0000-7efe5000	Deferred        version
PE	7eff0000-7eff3000	Deferred        wow64cpu
Threads:
process  tid      prio (all id:s are in hex)
00000008 affinity-photo-1.6.5.135.exe
	[Z:\home\empty\Downloads\affinity-photo-1.6.5.135.exe]
	00000009    0
0000000e services.exe
	00000062    0
	0000005b    0
	0000001d    0
	00000015    0
	00000010    0
	0000000f    0
00000011 explorer.exe
	00000025    0
	00000024    0
	00000023    0
	00000012    0
00000013 winedevice.exe
	0000001a    0
	00000019    0
	00000018    0
	00000014    0
0000001b plugplay.exe
	0000001f    0
	0000001e    0
	0000001c    0
0000004f (D) C:\users\empty\Temp\AffinitySetup\a3d22e29-c4b5-11e9-2389-4ccc6a6e0641\SetupUI.exe
	["C:\users\empty\Temp\AffinitySetup\a3d22e29-c4b5-11e9-2389-4ccc6a6e0641\SetupUI.exe" /log=true]
	00000076    0
	0000006f    0
	0000006e    0
	0000006d    0
	00000068    0
	00000057    0
	00000053    0
	00000052    2
	00000051    0
	00000050    0 <==
00000059 mscorsvw.exe
	0000005f    0
	0000005e    0
	0000005d    0
	0000005a    0
00000060 mscorsvw.exe
	[C:\windows\Microsoft.NET\Framework\v4.0.30319\mscorsvw.exe]
	00000065    0
	00000064    0
	00000063    0
	00000061    0
00000069 msiexec.exe
	[C:\windows\syswow64\msiexec.exe -Embedding 79]
	0000006a    0
00000077 explorer.exe
	0000007b    0
	0000007a    0
	00000079    0
	00000078    0
System information:
    Wine build: wine-4.12.1.r1.gaccf1895 ( TkG Staging Esync )
    Platform: i386 (WOW64)
    Version: Windows 8.1
    Host system: Linux
    Host version: 5.2.9-arch1-1-ARCH

 

Share this post


Link to post
Share on other sites

For me this is not working. Half of the winetricks command end/freeze with an empty window open (but work fine with the default installed wine).

However since it's working for you, I'm optimistic this will work itself out!

 

On 7/28/2019 at 1:09 PM, toluschr said:

I tried to run Affinity previously, but only got to the point of "VK_CHILD_WINDOW_RENDERING" not being implemented and after not using Affinity Photo for a long time to stay with Linux I got the following message on Discord:

image.thumb.png.54e95c55fadd09b30cd8568d0af1e4d4.png

 

Where can we track when this patch is being merged to mainline? I prefer to (wait for and) install a package version from the beta repository, so not to mess with the ability to run my existing wine apps.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×